QNAP packages for testing

I’ve made QNAP packages for those who want to run the web GUI on a QNAP NAS:

Marvell ARM: https://acrosync.com/duplicacy-web/duplicacy_web_qnap_arm_x19_1.4.1.qpkg
Mindspeed ARM: https://acrosync.com/duplicacy-web/duplicacy_web_qnap_arm_x31_1.4.1.qpkg
Annapurna Alpine ARM: https://acrosync.com/duplicacy-web/duplicacy_web_qnap_arm_x41_1.4.1.qpkg
AnnapurnaLabs AL324 ARM 64bit: https://acrosync.com/duplicacy-web/duplicacy_web_qnap_arm_64_1.4.1.qpkg
Intel/AMD x86: https://acrosync.com/duplicacy-web/duplicacy_web_qnap_x86_1.4.1.qpkg
Intel/AMD 64bit: https://acrosync.com/duplicacy-web/duplicacy_web_qnap_x86_64_1.4.1.qpkg

Follow this guide to determine the CPU type and then select the corresponding package to install.

If the selected package can be installed and run successfully please post below to let me know. I only have a TS-212 which has a Marvell ARM cpu so only the arm_x19 package has been tested.


I have qnapclub repo installed on my NAS and the maintainer of the CLI version does not update it. I tried several times to reach out for him. I just replaced the executable by myself. It has nothing to do with the webui but if you are on qnap at the time it may be worth looking at it. I guess it is not in your interested that qnapclub is sharing outdated software.




2020-03-24 13:26:11





I tried to upload the Intel/AMD 64bit qpkg file onto a TS-453Be model. But the AppCenter manual install menu said the file “does not have a valid digital signature to confirm its publisher or file integrity”.

Not sure if this is the QNAP AppCenter only checking for QNAP signatures or if it is not using the same chain of trust as the Duplicacy file.

Did it offer an option to ignore the warning and continue the installation? These packages won’t be digitally signed until they are accepted into the App Center.

I don’t know if a QNAP package for the CLI would be useful. Downloading the CLI from the github release page and then placing it in a directory included in PATH should be easy enough.

Yes correct :slight_smile: nevertheless they share this old version.

Mixed up the numbers? On my TS-431+ I needed “Annapurna Alpine ARM”
Is it correct that there is no trial license?
The name of the package should be “duplicacy web” and not duplicacy. It collides with existing package “duplicacy” in qnap club store.

The x41 package should work for TS-431: https://forum.qnap.com/viewtopic.php?t=153505

After you install the package it should automatically download a 30-day trial license. If it doesn’t work please let me know.

1 Like

Ok fine I thought it stands for TS-x31

It does not :frowning:

This topic was automatically closed after 20 days. New replies are no longer allowed.