Ready to give up on Duplicacy and go back to restic

I’ve used restic for a long time and never had an issue with it. I decided to try duplicacy and I was definitely impressed with the speed. However my journey has been difficult. I gave up on the CLI because I’ve always had problems getting it to work the way I wanted it to. I switched over to the GUI and this has been working fine. I was ready to purchase a license for it when I tried to test one more thing. RESTORES. Restoring from your original computer does work GREAT and speed is impressive. However if your main computer crashes and you have to configure a new computer, I’ve found it impossible to restore anything from any of my storages. What good is a backup solution if you can’t restore files if you get a new PC. With restic, you simply have to install the CLI executable and run the restore command and supply your password. That’s it! No re-initializing an existing storage, etc.
Goodbye duplicacy :frowning:

The restore is very straightforward: configure storage, restore.

This is a really weird thing to throw in the towel over – but if the duplicacy’s problem is that it’s not restic – then, I guess, it’s not fixable.

To make this actionable – please share what specifically did not work for you. The community will either direct you to a solution, or thank you for a bug report.

2 Likes

duplicacy config located in client side. You could just copy the .duplicacy folder and restore.

Hi, I have a similar problem. Impossible for me to configure on a 2nd computer the same storage as on my first computer. The indications is : “The storage has already been initialized. Enter a unique name for the storage.”
So I try to use exactly the same label BUT thze green validation button isn’t operational. So, impossible to restore. Please help for that. Thank you.

EXACTLY one of my issues. With other backup solutions, you don’t need to mess around with re-initializing pre-existing storage, etc. Duplicacy seems to only be good for restoring files from your original computer that you created the backups from. If you encounter a real disaster and need to restore files from another computer it doesn’t work as you’ve seen yourself.

I tried that and it doesn’t work. It complains about the storage already been initialized.

Thank you for taking the time out to respond. I do appreciate that. But to state the restore is very straightforward is unfortunately not true. Yes if you are restoring files from the original computer, you are right. But if you encounter a real life situation where your computer dies and you need to restore files back to another computer or if you had to reformat your hard drive, good luck getting restore to work. It is cumbersome and confusing :frowning:

If you see the page below, then everything is good and you just need to click the Add button.

This is not an error message. The green icon means the name you enter is unique and the Add button should be enabled when this icon is green.

No, the green button isn’t active. I’ve tried with the same storage name that on the first computer and with a different name. IMPOSSIBLE ! Where could be the problem ?

Can you upload a screen shot?

I’m honestly not trying to be rude but the problem is Duplicacy :frowning:

I’ve used all of the following backup applications without any problems and duplicacy is the only one I can never get to work:

attic
borg
restic
rclone
Duplicati
rsync
Duplicity

Step 1 OK.
arriving on the 2nd page, no green button. It appears when starting to enter the storage name but never active

It is the ‘Add’ button near the bottom of the dialog, not the green check icon next to the storage name input box.

I have no Add button. No other button on my screen. And what is really penible. If I try to touch the screen, I lost every thing and have to restart to write all the data for my storage. grrrrr

This one doesn’t work. And it appears only when I enlarge my windows. Terrific :frowning: And trying to use it I lost one more time all the date of my storage :frowning:

If you’re using Chrome, click the setting button on the top right corner, decrease the zoom, then you should be able to see the Add button.

There is some disconnect here. Steps to configure the duplicacy from scratch to do a backup of a new computer and restore to the new computer are exactly the same, by design, up to the actual command — restore or backup.

In fact, for restore there are fewer steps — you don’t need to create schedules and backup jobs.

The key to understand here is that for duplicacy needs target storage configured to do anything useful with it. This is the case both for backup and restore workflow.

Once storage is added — to backup you create a backup schedule, and to restore — go to restore tab.

In other words, to backup:

  1. Instal duplicacy
  2. Add storage.
  3. Add backup task
  4. Configure schedule.
  5. Backup.

To restore

  1. Install duplicacy
  2. Add storage
  3. Restore.

Less step, less cumbersome.

I see there is some communication gap but I’m not sure where. Can you elaborate on why is the second feels cumbersome?

1 Like

I understand and this is exactly what I want to do. My back-up is done now… after some tries…
But for me it’s just impossible to add a storage on the 2nd PC, when it’s already initialized. That’s the point And that’s why I can’y restore my back-up.

1 Like

Exactly the same issue I have. No other backup solutions make you initialize something that already exists.

For example for restic:

  1. Download single executable restic file.
  2. Initialize remote storage with a password
  3. Backup files.

To restore files on a new PC:

  1. Download single executable restic file.
  2. Run restore command for the remote storage. Supply the password you initially created when first backed up.

That’s it! No need to re-initialize storage, etc.

Just type in your password and restore. Restic knows about everything

This looks like a bug. The dialog shall not be allowed to extend beyond the screen, or at least the scroll bar shall be added. In this case here specifically, there is all that wasted space that can be simply removed

1 Like