Recently started getting x509 certificate error with B2

I have a Duplicacy setup on Synology (in docker) which has been working fine for months.

However, I just noticed a day or 2 ago that I started getting the following error from Duplicacy. None of my backups or pruning have succeeded anymore.

Even a new setup on Windows has not been successful with a new API key. Logging into B2 via website does work.

Anyone else encounter this issue? Thoughts?

2021-04-01 01:39:18.148 ERROR STORAGE_CONFIG Failed to download the configuration file from the storage: Head x509: certificate is not valid for any names, but wanted to match

1 Like

I’m running into the same problem. All my backups to B2 are failing, and I cannot add a new storage on b2 (it hangs at “Checking the storage at b2:///”).

I figured out what was happening for me. Maybe it is similar to your setup?

I have pihole running on my network as my primary DNS server. Does a great job blocking ads and a variety of other things.

I have subscribed to some blocklists which are refreshed occasionally.

I did a check and noticed that was actually getting caught by one of the blocklists now. For whatever reason, it wasn’t returning like I would have expected. Whichever IP it was getting redirected to was responding to HTTPS requests, but just not as

Anyhow, what solved it for me was to put on the whitelist for my pihole and my backups started working again.

Thanks, that solved it for me!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.