Response Code 409?


#1

I’ve just recently started using Duplicacy on Windows (the GUI) to backup my User folder on a PC (i.e. C:\Users[me]). Set it to run 3 am every night. When I got up this morning, I noticed it was still running. Checked the logs and since about 3:12 am there were hundreds of entries like this:

03:12:34.802    Response code: 409; retry after 742 milliseconds

Didn’t seem to be stopping after 4 hours or so, so I decided to stop it. However, when I hit the Stop button in the Job tab, everything remained grayed out in the Job tab, with the Stop button saying “Stopping”. I can still switch between the Job and Logs tab, but that’'s about it. The log shows this:

07:35:26.000    program exited with status code -1

I waited a few minutes but eventually decided just to kill Duplicacy from Task Manager.

Tried searching the forums for this but didn’t manage to find anything. If anyone has any suggestions on how this could be fixed I’d very much appreciate them.

I installed Duplicacy as Admin, enabled for all users, and installed the service. Volume Shadow Copy was also turned on for this job. There is only one job running. On Windows 10.


#2

Which storage backend are you using? The errors could be caused by rate limiting imposed by the storage provider.

As for the other issue – I can confirm this is a bug that a scheduled job can’t be stopped once it starts running. I’ll fix this in the next update.


#3

Thank you for the quick reply and for letting me know about the bug. I’m using MS OneDrive (personal) for backend storage. Is there any way to diagnose whether it is in fact rate limiting by the storage provider? Or if not, and assuming that is the cause, would you have any suggestions as to how I might be able to avoid running into the error? For example, is there a way to throttle back Duplicacy when that happens?


#4

What operation caused these 409 errors? Did they happen during a backup operation or a prune operation? Can you post a few log lines before this error?


#5

I’m terribly sorry Gilbert - I should have checked the detailed logfiles before asking the first part of my question. This happened during backup, specifically during the upload process. Following is from the detailed logfile with a few additional lines:

2019-02-28 03:12:34.802 INFO ONEDRIVE_RETRY Response code: 409; retry after 742 milliseconds
2019-02-28 03:12:35.810 INFO UPLOAD_PROGRESS Uploaded chunk 861 size 3004233, 5.68MB/s 07:30:40 2.6%
2019-02-28 03:12:35.906 INFO UPLOAD_PROGRESS Skipped chunk 862 size 1299304, 5.68MB/s 07:30:32 2.6%
2019-02-28 03:12:36.010 INFO UPLOAD_PROGRESS Skipped chunk 863 size 3901131, 5.68MB/s 07:30:44 2.6%
2019-02-28 03:12:37.092 INFO ONEDRIVE_RETRY Response code: 409; retry after 91 milliseconds
2019-02-28 03:12:37.913 INFO UPLOAD_PROGRESS Uploaded chunk 864 size 2446018, 5.68MB/s 07:31:05 2.6%
2019-02-28 03:12:38.649 INFO UPLOAD_PROGRESS Uploaded chunk 865 size 3898702, 5.67MB/s 07:31:17 2.6%

Any thoughts you may have on how I might be able to avoid the rate-limiting issue would be most appreciated.


#6

I’m not sure if this 409 code was caused by rate-limiting. They are actually treated as warnings due to the retry mechanism, so it was still making progress.

If you turn on verbose logging you may be able to know which API call returns the 409 code.


#7

Thank you. I will give that a try, though as an aside, the problem seems to have gone away.


#8

For anyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any #support topic: you can mark the post that solved your issue by ticking the image box under the post. That of course may include your own post :slight_smile: