Restore a specific folder/files - Pattern on Windows machine

Hi All,

I’m trying to restore a specific folder or a set of files and I’m following some of the topics such as: Duplicacy Issue: "Restore" restores only one file instead doing all selected files or the whole folder

I’m trying this on Windows, and used a command like:

duplicacy_win_x64_2.2.0.exe restore -r 1 – “Test*” -stats -threads 10

but the restore process restored all the files, and not just the ones under Test folder. I tried the “list -files” command, and it seems that even on Windows I should specify the pattern using Unix/Linux file conventions like “Test/*”. Is this correct?

Thanks.

Try updating to 2.2.1…

1 Like

@Christoph, thanks for your response!

  1. I tried version 2.2.1 to restore a single on Windows, and it works well now.

  2. Also, for restoring an entire sub-directory on Windows (even with 2.2.0), I learn that I have to specify the following command-line:

duplicacy restore -r 1 -stats -threads 10 – Test/* and

NOT duplicacy restore -r 1 – Test/* -stats -threads 10.
In other words, the pattern must be at the very end of the command-line (I think help message makes it clear, but I didn’t pay attention).

Moderators, this ticket can be closed. Thanks again for the quick response!

2 Likes

For anyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any #support topic: you can mark the post that solved your issue by ticking the image box under the post. That of course may include your own post :slight_smile: