Saving SSH password


I’m setting up automated backup on windows to NAS via SFTP. Every time I run the backup manually I’m asked to enter SSH password. In fact I’m using private key to connect to I assume this is a password for the key (which is blank).
How do I save it to be able to run from scheduler?
I’ve tried setting DUPLICACY_SSH_PASSWORD= and also adding this to preferences:
“keys”: {
“ssh_password”: “”
Still get the promt every time.

Solved this by adding -background flag:
duplicacy -background backup -storage nas


Well done!
And welcome to the forum!!! :wave:

1 Like