Scheduled check downloads 100GB+ cache files

Using duplicacy_win_x64_3.0.1.exe it seems there could be a bug when checking repositories.
I am discovering our server will run out of disk space because over 100GB+ cache files are downloaded during the check process. The check process also fails due to lack of space to download more chunks.

What arguments are you giving to check command?

Hi saspus the scheduled check was created through the web-gui

Options: [-log check -storage xxx -threads 10 -a -tabular]


Check downloads chunks that are needed to unpack snapshots to then verify presence of chunks the snapshots reference. 100Gb worth of metadats chunks sounds a bit high, but not impossible if you have millions of files backed up and/or long version history.

Or are you saying the bahaviour suddenly changed after e.g. sw update?

Before the update the server had around 30-40GB free space and check will complete. After the update doing a scheduled check, the check failed as it suddenly consumed all the space. Clearing the cache folder did not work as the next scheduled check also failed as it ran out of space.

This looks like an actual problem than needs to be solved.

Pretty much any modern filesystem requires at least 10-15% free space, so is the source volume 400GB? Or is duplicacy running on a different volume? You can redirect its temporary folder to another volume, where there is more space.

How large is the size of the backup dataset, how many snaphsots are created, and how many files are in a snapshot, ballpark. This will help understand if 100GB of metadata is reasonable.

100GB+ metadata would be very, very, unusual. I have one pretty large repo (~20TB, millions of files), and it doesn’t reach 2GB in cache.

OP, have you by any chance increased default chunk size (a lot)? That might do it.

You probably need to run the prune command to clean up the cache: Cache · gilbertchen/duplicacy Wiki · GitHub

The repository is about 1.3TB with 22892 revisions.
I tried to do a prune but failed because it ran out of cache space.
I will try again when I have larger hard drive and set the /tmp directory to the new drive.