Setting Up E-mail Notifications - Then Non-Responsive Web UI

I was trying to setup e-mail notifications for Duplicacy Web on Debian 9. An error popped up during setup and I now see the other post on the forum that explains why.

Unfortunately, I did not see that post before apparently managing to mess things up a bit: When I saw the X.509 error, I thought it might be because I was specifying port 25 for the server. So I tried port 465, just to see if that might do the trick. When I clicked “Test”, nothing happened - no error message popped up, nothing. But the popup then became unresponsive. After a minute or two, the dialogue box disappeared. When I clicked on “Send Notifications” it just checked the box (and unchecked it if I clicked again) - no dialog box popped up to enter in details.

I then noticed that the whole webui had become non-responsive. When I tried to reload the page in my browser, Duplicacy was non-responsive.

Normally I would just do in and stop the Duplicacy service, but when I was doing all of this a rather large backup job was running (and is still running), so I’d prefer not to do that while that job is still running. ps -A show that duplicacy_linux and duplicacy-web are still running.The last few lines of the duplicacy-web log are as follows:

2019/08/01 14:53:40 Failed to send the email: dial tcp [ip address of mailserver]:465: connect: connection timed out
2019/08/01 14:53:40 GET /schedule
2019/08/01 15:09:34 GET /schedule

Is there a way to somehow reset the webui without killing the backup job that is currently running?

It would perhaps also be helpful to understand what I did wrong here. I would imagine an error should be shown if I enter an invalid port, but didn’t expect it to kill off the webui altogether.

Any thoughts or suggestions would be most appreciated.

Well, it looks like all I needed to do was to wait a while. Web UI came back all on its own. Still somewhat odd behaviour though.

1 Like

Note that that post is about the GUI version, not the Web edition aka web ui.