SFTP Error Uploading Chunk - Permission Denied


#1

OK I am getting a ERROR: Failed to upload the chunk aksdfjoaksdjfoajdof
sftp: “Permission Denied” (SSH_FX_PERMISSION_DENIED)

I am pretty sure I am using all the correct passwords. What would you try?

Thanks!!!


#2

in your SFTP URL – did you specify the absolute or relative (to the home directory) path?

i.e. sftp://user@server//backups/duplicacy vs sftp://user@server/backups/duplicacy ? (note double //)

Also, if your server happens to be Synology - there is specific quirk with that.


#3

I specified the absolute path. I did it the same way I have a couple other computers configured. Also- according to the logs- it seems that a connection is established as it finds snapshots etc…

Not sure what is going on yet… :frowning:


#4

Most likely the user account you’re using to doesn’t have permission to write to the directory that this particular chunk is uploading to. This could happen if that directory was created by a different user.


#5

Looks like that is what happened.

The archive was created on a locally connected HDD… then I took it to my house and copied it onto my NAS. Then tried to connect the original repository computer to my NAS via SFTP.

As you suspected, the owners were different… and that is what was preventing the remote computer from connecting and overwriting etc.

A little chown and chgrp seemed to do the trick.

Thanks!!!


#6

For anyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any support topic: you can mark the post that solved your issue by ticking the image box under the post. That of course may include your own post :slight_smile: