SFTP Hostname instead of IP address - email says "invalid storage" [SOLVED - PEBCAK error]

Please describe what you are doing to trigger the bug:
Backup storage set to hostname:port, instead of using IP address. I had a different storage location set to IP address before, which all worked fine. Windows 10

Please describe what you expect to happen (but doesn’t):
I expect the email error to report consistently what the log on the device, and for the backup to have a genuine fail - as storage error seems pretty ‘final’.

Please describe what actually happens (the wrong behaviour):
Backups seemed to work, I could also restore a file. The emailed log reports an error. I checked the log in the WebGUI and it doesn’t say ‘Invalid storage’ anywhere.

I am using {{status}} in the subject.


Back up C:/Users@localhost to storage Win10-Stuff, status: Invalid storage, log file:

Invalid storage means it couldn’t find the storage with the name Win10-Stuff, so please make sure this storage exists. I don’t think the backup would work with an invalid storage name.

Note this doesn’t affect me, i will be using a fixed IP address, but i thought i should report what i found.

I wrote up this big email with all the info, and i realised that there was another job in the schedule which was pointing to a defunct storage configuration. The email didn’t seem to differentiate between the two jobs which confused me. It could be because i’ve trimmed the email output a bit with {{status}} and excluded logs:


I deleted the offending job and left the hostname storage job (no IP address) and ran backups again and the email gave me success and no invalid storage. So now i know the cause was the other job in the schedule (my bad!).

But the email from the earlier failed jobs confused me because it didn’t differentiate between two jobs (one good, one not) run on the same schedule. So it said error - but it wasn’t obvious where it came from. Bold is my emphasis.

And after seeing that here - now i finally get it. There’s two “Back up C:…” lines :smiley:

Oh dear me :smiley: But you see, Win10-Stuff is just called ‘hostname’ for some reason on the job that uses the hostname instead of IP address. So maybe that’s something that could be improved? :innocent:

Subject: Win10-Stuff Backup :: error

Back up C:/Users@localhost to storage Win10-Stuff, status: Invalid storage, log file:
Back up C:/Users/test/Desktop@localhost to storage hostname, status: Completed, log file: backup-20200522-140001.log

Running backup command from C:\ProgramData/.duplicacy-web/repositories/localhost/1 to back up C:/Users/test/Desktop
Options: [-log backup -storage hostname -stats]
2020-05-22 14:00:02.300 INFO REPOSITORY_SET Repository set to C:/Users/test/Desktop
2020-05-22 14:00:02.302 INFO STORAGE_SET Storage set to sftp://backup-user@Pi2B-Backups:7890//mnt/Backups/Win10-Stuff
2020-05-22 14:00:08.367 INFO BACKUP_START Last backup at revision 1 found
2020-05-22 14:00:08.367 INFO BACKUP_INDEXING Indexing C:\Users\test\Desktop
2020-05-22 14:00:08.367 INFO SNAPSHOT_FILTER Parsing filter file \?\C:\ProgramData.duplicacy-web\repositories\localhost\1.duplicacy\filters
2020-05-22 14:00:08.367 INFO SNAPSHOT_FILTER Loaded 0 include/exclude pattern(s)
2020-05-22 14:00:08.686 INFO BACKUP_END Backup for C:\Users\test\Desktop at revision 2 completed
2020-05-22 14:00:08.686 INFO BACKUP_STATS Files: 14 total, 3,860M bytes; 0 new, 0 bytes
2020-05-22 14:00:08.686 INFO BACKUP_STATS File chunks: 1261 total, 3,860M bytes; 0 new, 0 bytes, 0 bytes uploaded
2020-05-22 14:00:08.686 INFO BACKUP_STATS Metadata chunks: 3 total, 95K bytes; 1 new, 2K bytes, 1K bytes uploaded
2020-05-22 14:00:08.686 INFO BACKUP_STATS All chunks: 1264 total, 3,860M bytes; 1 new, 2K bytes, 1K bytes uploaded
2020-05-22 14:00:08.686 INFO BACKUP_STATS Total running time: 00:00:01