Shadow copy creation failed: DoSnapshotSet didn't finish properly

How do i fix this on server 2012

Shadow copy creation failed: DoSnapshotSet didn’t finish properly

This is caused by the DoSnapshotSet call taking longer than 60 seconds (line 476 in duplicacy_shadowcopy_windows.go)

	if !async.Wait(60) {
		LOG_ERROR("VSS_SNAPSHOT", "Shadow copy creation failed: DoSnapshotSet didn't finish properly")
		return top

I need to think of a way to allow this value to be customized, but for now I can get you a special build with a larger value if you want.

so this doesnt have to do with the app not actually being a VSS writer?

there isnt a ton of data 200 GB… its going to be worse on my customers who have a terabyte of data or so

But yes i really need help to fix this…

Can i take apart the build and change it myself… just tell me how… i’m not sure codeish

but i can try

To build the CLI executable, follow the instructions here: Build Duplicacy from source

Once you have the executable, rename it to duplicacy_win_x64_2.0.9.exe and copy it to C:\Program Files (x86)\Duplicacy or C:\Users\username\AppData\Local\Duplicacy to overwrite the existing one.

yeah…i got completely lost… i need to take you up on your offer of a custom build…

can we connect and get that done Gilbert…i need a long enough time to accommodate at least 1TB for many of my clients… the one that got hung was only 200 mb

Here is the custom build:

The timeout has been increased to 180 seconds. It is perhaps enough for most cases but if not I’ll add an option to set to arbitrary values.

thank you so much… i will report back

what does this mean??

08:01:45.639 Failed to list subdirectory: open E:/.duplicacy\shadow\/System Volume Information: Access is denied.

it seems like the shadow copies still failing?? it is because of this??

do i need to exclude this .duplicacy directory from the backup?

That just meant that you don’t have the permission to access E:\System Volume Information, even with shadow copy.

You can exclude this directory by adding this line to .duplicacy/filters:

-System Volume Information\

that worked…

however i keep getting this error on one of my new machines

18:57:58.948 Shadow copy creation failed: StartSnapshotSet returned 80042316

This error may indicate that another backup application was running at that time:

// MessageText:
// Another shadow copy creation is already in progress. Wait a few moments and try again.

There is a backup program that does a full metal backup to disk nightly…

However it runs at 9pm and is done by 1 or 2am

Maybe there is another one. Windows itself could create shadow copies from time to time if you enable file history. The Windows event log may have more information.

it’s hit or missing… it doesn’t always happen

Is volume shadow copy similar to OFO… open file option

I am getting alot of errors that files can’t be backed up because they are open

If you can find out how long the other shadow copy operation takes to finish from the Windows event log, we can then decide if it makes sense to keep retrying and wait until the other operation is done.

is the volume shadow copy the reason that it wont back up some of the files because they are in use or open?

love your product by the way… its pretty bad ass…

If it says they are in use then turning on the VSS option should help. If it is an access error then it is usually caused by insufficient permissions.

turns out the issue was with one of the vss writers…a simple reboot fixed it…Another way to fix it is to start a windows backup of the just the system state and let it fail… that also fixes the state of the vss writers

now the issue i am having is on reboot the app starts from a service and it is missing all of the saved fields…