ShadowCopyTimeout not working


#1

going over some posts i noticed with 2.10 and above you can add a registry string called ShadowCopyTimeout in HKLM or HKCU under the duplicacy and the corresponding job and its supposed to let you overwrite the amount of time needed to create a shadowcopy

i have done so and set it to 360… which i assume means 360 seconds…

i shut down the program… opened it as admin and tried to run a job and it still errors out with the following

12:34:26.645 IVssAsync is pending for more than 60 seconds
12:34:26.645 Shadow copy creation failed: DoSnapshotSet didn’t finish properly


#3

That is a per job registry value, so did you add it under HKCU\Software\Duplicacy\Job{0,1,2,…}?

If you set it correctly, the log will show the -vss-timeout option passed to the backup command.


#4

not sure if that will work… but that’s how i set it up


#5

i believe its under hklm… thats the only job that matches my settings…


#6

also the previous version was a custom made package that you built that had the timeout built… when i installed the newest version i shutdown the app and installed over the top… im in bit of a bind here because i cant back anything up unless its at 3am and i disconnect all of the shares


#7

That registry setting looks correct to me. Again, you should be able to the -vss-timeout option in the log, like:

20:13:12.000    Command: duplicacy -background -log backup -stats -vss -vss-timeout 600

#8

it doesnt pass the time out to job


#9


#10

Did you restart Duplicacy after adding ShadowCopyTimeout (right click the system tray icon and select Quit to close the current instance first)?


#11

yes… and reboot the server


#12

Could be the other job. HKLM\Software\Duplicacy\Jobs contains the indices of all jobs.


#13

im just going to kill the job,… kill the process… remove the directory… remove the registry entries associated with it and start over…


#14

yeah that worked… i added the string back and started up and it worked…

so this might be some anomaly because i had a custom version installed that i didnt remove and just upgraded …

all works now… set 360 for the string and it worked perfect… thats a great addition