SNAPSHOT_CHECK excluded from log still leaves check table of all revisions

I’ve been using the email with the log field, and it’s definitely awesome. However, for each of the check jobs I run and list “SNAPSHOT_CHECK” to be excluded, I still get the table of all revisions. It properly removes all the log files at the beginning though such as SNAPSHOT_CHECK All chunks referenced by snapshot backupID at revision 1 exist

What’s in my email schedule:

What is included in my email:

2020-03-08 06:59:42.426 INFO SNAPSHOT_CHECK 
  snap    |  rev |                          |  files |    bytes | chunks |     bytes |   uniq |     bytes |    new |     bytes |
  backupID|    1 | @ 2019-04-27 22:52 -hash |  12336 |   7,454M |   1318 |    4,819M |    548 |    1,745M |   1318 |    4,819M |

Please describe what you expect to happen (but doesn’t):
I would expect the table to not be included in the email when “SNAPSHOT_CHECK” is listed in excluded logs.

Please describe what actually happens (the wrong behaviour):
The table under the log ID of “SNAPSHOT_CHECK” is included as noted above.

These stats lines are not in the same format as other log messages so they don’t really have a Log ID. This can be fixed by assigning SNAPSHOT_CHECK as an artificial Log ID to them.