Snapshot not deleted when pruning

prune

#1

I’m trying to delete one copy of vm made vertical backup.
Duplicacy I have on linux initiated by example
mkdir repo,
cd repo
…/duplicacy init repo sftp://user@ip/VMs
…/duplicacy prune -id vm1@esxi6 -r 1

received message: Deleting snapshot vm1@esxi6 at revision 1
and instead of deleting the repository on sftp, the chunks from sftp are copied in the repo / .duplicacy / cache directory.

What am I doing wrong?


How to use Duplicacy on windows to prune ESXi backups from Vertical Backup
#2

This is how Lock-Free Deduplication works: the fossil collection step only deletes snapshot files and the chunks will be deleted in the fossil deletion step.

If you need to remove chunks immediately, run the prune command with the -exclusive option but make sure no backup is running at the same time.


#3

Despite the use of the exclusive option:
duplicacy prune -id vm1@esxi6 -r 1 -exclusive
the copy is not deleted and the deduplicacy cache records the snapshots of all virtual machines.


#4

The disk for the copy I have almost 100% full, free 384MB from 1.8TB. can it matter? What can I do to delete old copies?


#5

You may need to run duplicacy prune -exclusive -exhaustive to remove unreferenced chunks if there were aborted backup or copy commands, but could you please run duplicacy check -a -tabular and post the results here to show how large existing backups are?

The cache only store metadata chunks; all file chunks are not stored in the cache.


#6

In fact, only 8 GB of data has been saved in the cache. Prune worked several nice hours and the copy was removed. Thanks.


#7

For anyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any support topic: you can mark the post that solved your issue by ticking the image box under the post. That of course may include your own post :slight_smile: