Ssh sftp no longer working - DNS completely broken in latest docker

It’s been fine for the last 5 months but last backup didn’t work and I’m getting the same error trying again now:

Running backup command from /cache/localhost/5 to back up /backuproot/backup
Options: [-log backup -storage hetzner-ssh -threads 10 -stats]
2024-05-15 01:21:01.446 INFO REPOSITORY_SET Repository set to /backuproot/backup
2024-05-15 01:21:01.446 INFO STORAGE_SET Storage set to s
2024-05-15 01:21:21.458 ERROR STORAGE_CREATE Failed to load the SFTP storage at s dial tcp: lookup on read udp> i/o timeout
Failed to load the SFTP storage at s dial tcp: lookup on read udp> i/o timeout

Looks like your Tailscale Magic DNS failed.

sftp works fine through WinSCP. I’m only having the issue with duplicacy.

This error has only been occurring since I updated the container yesterday. How do I roll back?

It looks like it can’t resolve any hostname at all and this is just a DNS issue. From within the console:

 # ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=55 time=28.196 ms


# ping
ping: bad address ''

Looking at


I get

# resolv.conf(5) file generated by tailscale
# For more info, see


I can ping fine on host machine.

However I can’t ping from within the docker.

Looks like maybe docker doesn’t work with tailscale any more?

Okay I’m sorry this was actually a tailscale bug.

I fixed it by running tailscale set --stateful-filtering=false on the host.

1 Like


The is definitely a Tailscale DNS. I did not know Tailscale have their own firewall. Unclear why would they device to block DNS traffic though.

As a small aside:

I have played with Tailscale a bit in the past. In the upside I like the UI and scheninigans

The downside is that it’s L3, and not much different from regular site-to-site VPN.

ZeroTier, while having much uglier UI, works on L2. This avoids all the TCP/IP shenanigans and makes mDNS possible. You can reach all devices in the virtual network by their .local names and not need mess with hostnames and/or addresses and/or DNS.

1 Like

Failed to create the sftp client: dial tcp: lookup on read udp> i/o timeout

I get this error when trying to add a SFTP storage.

Was working yesterday before I updated the docker image.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.