Synology NAS : Duplicacy fails to initialize the storage usb HDD

Hey , new to Duplicacy and I’m hoping it’ll work for me!
I’ve got a Synology DS920+ and a WD 20TB exFAT HDD attached via USB to the NAS.
I’ve got Duplicacy installed on the NAS as a standalone app (not containerized).

I go into the web-browser interface for Duplicacy, click Storage, and the Storage Configuration pops up. I choose Disk, and then in Directory scroll all the way to the bottom to pick “volumeUSB1” which is the external HDD plugged into the USB of the NAS. I select it, hit Continue, and then get to Configure the Storage. I give it a name “USB” and hit Add and get this:
“Failed to initialize the storage at /volumeUSB1: Failed to configure the storage: open/volumeUSB1/config.qfxjvvwh.tmp: permission denied”

Now I just want to clarify that I already have given permission for duplicacy to access (read/write) back in the Control Panel: Shared Folder: (click on USB HDD and Edit, then click Permissions) and then choose System Internal User, and for duplicacy I give it read/write access.

And still no love for me :frowning:


Thanks for your time and assistance.

I would strongly suggest use ext4 filesystem instead.

I assume you have also created a user for duplicacy to run as, right? How do you launch it to ensure it uses the configured user?

Create a folder on your usb drive and use that as Duplicacy target. I vaguely remember there being some issues accessing root mount point.

Once you try all that and still no dice — check actual permissions on the mount and your duplicacy subfolder:

ls -al <path to usb drive mount>

note1: the volumeusb1 is not sticky — if you connect disks in different order - it may get volumeusb2 name next time.

note2: when you init storage make sure to enable erasure coding, it will somewhat increase the time before you lose data to corruption.

Note3: I would reconsider backing up a nas to a single usb drive in the first place. Medium you backup to shall be more reliable than the source. And here you have a scrubbing raid array with data consistency guarantees as source and a single rotting drive with no error correction as target. This backup would be fairly useless. Instead, backup to a cloud.


THanks for your detailed reply!

I’ll go step by step with your questions:

  1. I chose exFat cause it’s a 20TB ext HDD, and I read that ext4 only is good up to 2TB or so. Am I incorrect?

  2. I did not create a user for Duplicacy as there is already a Duplicacy System Internal User. Are we required to make a regular user? I’ll do it now since you suggested it. Here’s hoping!

  3. Ah! DId not know there should be a target folder on the drive and I will do that as well.

Thanks so much for the rapid and learned reply. I really appreciate it, and I’ll get right back and let you know how it goes.


  1. Ext4 supports up to 1 EiB volume size and up to four billion files. ExFAT, was designed and optimized for small flash drives. When you go higher in size the space utilization efficiency drops (large block size) and if you go higher in number of files — performance plummets.
  2. Oh, did you install it manually or using Synology packages? If so, then everything shall “just work”, and the option 3 would be the only potential culprit.

OK, I’m right now reformatting the drive for Ext4. I also created a ‘user’ duplicacy1 (I can’t create a user ‘duplicacy’ because there’s already a System User with that exact name)(which is why I’m a little confused here)

I’ve given permissions out the wazoo with read/write for duplicacy and anything else I think could be related to duplicacy.

I hope this all works. I’d really rather not have to resort to HyperBackup. :frowning:

Made a regular folder (not shared) on the WD ext drive (reformatted to ext4) and called the folder “NASTY”. When I tried choosing the backup drive for duplicacy (root level) I get this error: " Failed to initialize the storage at /volumeUSB1: Failed to configure the storage: open /volumeUSB1/config.npanjdnp.tmp: permission denied "

When I try choosing the NASTY folder /volumeUSB1/NASTY/ i get this error “Failed to check the storage at /volumeUSB1/NASTY/: Failed to load the file storage at /volumeUSB1/NASTY/: mkdir /volumeUSB1/NASTY/: permission denied”

Interesting. Looks like some permission are not set somewhere.

Synology uses two sets of permissions — Linux permissions or ACLs. You can’t use both concurrently. I’m wondering if there is some issue with that?

OK, I think we can close this thread.

It’s now working.

How? I don’t know.

I have my 20TB Ext HDD plugged into the USB port of my NAS. In Windows explorer, I mapped a drive to that Ext HDD (Drive Z:). I then, for whatever reason, reinstalled the web version of Duplicacy, and went thru the steps and… it now just seems to work. (???) I’m sorry for taking your time, folks, I really don’t know what I did or didn’t do, but it all seems to be fine now, so , thank you very much for putting up with my noob-ish-ness.

Nah, don’t blame yourself. Synology software is incomprehensible. Maybe something glitched the first time you tried. Glad it works now.

you can mark your comment as a solution – “try again” is a viable method :slight_smile:

AND now it’s a day later and the same stuff… can’t establish a drive , it can’t create tmp files due to lack of permission

i think this is a sign duplicacy may not be for me :frowning:

What changed? Maybe path to usb drive changed?

If anything, this is a sign not to backup to usb drive. See Note3 in my original reply above.