The Application is unable to start correctly (0x000007b)

Please describe what you are doing to trigger the bug:
Trying to install Web-UI version.

Please describe what you expect to happen (but doesn’t):
Installer to start.

Please describe what actually happens (the wrong behaviour):
See the screenshot:
2020-03-30 23_42_37-duplicacy_web_installer_win64_1.2.1.exe - Application Error

I have installed latest redist packages and Windows is updated, W10 1909.

I found this page: windows - The application was unable to start correctly (0xc000007b) - Stack Overflow

The best way it appears is to run Dependency Walker on the installer:

Tried it, but without much of luck. Here is an output of WinDBG:

CommandLine: C:\Users\robb\Downloads\duplicacy_web_installer_win64_1.2.1.exe
Symbol search path is: srv*
Executable search path is: 
ModLoad: 00540000 00717000   image00540000
ModLoad: 77850000 779ea000   ntdll.dll
eax=00000000 ebx=028b2000 ecx=00000000 edx=00000000 esi=c000007b edi=00002000
eip=778c203c esp=02affaa8 ebp=02affb04 iopl=0         nv up ei pl nz na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000202
778c203c c20800          ret     8

Process seems to be terminated instantaneously. I wonder if this is a consequence of so-called DeviceGuard being enabled.

Ok, disabling ASLR for the binary has solved an issue. And here is the relevant config:

<AppConfig Executable="duplicacy_web_installer_win64_1.2.1.exe">
  <DEP Enable="true" EmulateAtlThunks="false" />
  <ASLR ForceRelocateImages="false" RequireInfo="false" BottomUp="false" HighEntropy="false" />
  <ChildProcess DisallowChildProcessCreation="false" Audit="true" />

Thanks for sharing the fix. This is an issue with the NSIS installer maker. Maybe it is time to use a different installer maker, like MSI.