Unable to install Web-UI on Synology DSM-7.1 (DS223j)

I’ve just tried to manually install this version


on a brand new Synology DS223j, which has got an ARM rtd1619b processor.
But unfortunately it says that the package isn’t supported by the platform or not compatible to the DSM version (7.1 in my case).
Do you have any clue, what could be the reason:

  • isn’t the 1619b supposed to be the same platform as the 1296?
  • or is it a Problem of the spk being compiled for DSM 7.0?

Thanks for every hint!

I can’t answer this questions, (let’s wait for gchen) but I want to point out that your appliance has 1GB of ram total. This is barely enough to run the OS leaving literal crumbs for filesystem cache. Running duplicacy there will result in one of the following:

  • duplicacy will run out of ram and get killed
  • duplicacy will consume most/all the remaining memory, consequently purging the filesystem cache, and murdering any remaining hope of getting any performance from this device.

I would strongly suggest to use that device as a nas only and run duplicacy on another host. It will be barely able to keep up serving data over NFS (I would not even use samba, you want all the ram possible to stay uballocated — it will then be utilized by filesystem cache; at least to hold metadata), let alone running apps.

Just checking back in on this one, I’m on a DS223 (not J) with 2GB RAM, but the same rtd1619b platform. Is there at least a tutorial anywhere to manually create/install/wrap so I can run on this box?

Still no solution at hand for that architecture?

According to Synology, rtd1619 and rtd1619b are different so their packages are incompatible: https://kb.synology.com/en-global/DSM/tutorial/What_kind_of_CPU_does_my_NAS_have

@saspus has a nice guide on how to manually set up Duplicacy Web on Synology:

my question is more or less if you plan to support rtd1619b as a Synology packages anytime soon,
also taking into account that those Synology NAS (DS124, DS223, DS223J and DS423) are quite widely spread…

I was hesitant to support rtd1619b because they all have a limited amount of memory (1 or 2 GB). Let me run some tests to see if the memory could be an issue.

Hi again,
sounds good for me :slight_smile:
Just for your informations:
We’ve been running version 1.7.2 according to the manual information instructions provided by @saspus
on a DS223j (beeing the lowest spec one with just 1GB of RAM) for a year now without any problems regarding stability and / or speed.