Unable to restore single file

Using the following command, I get the following output:

duplicacy restore -r 502 2018-05-05_20-50-24-vid_20180505_125024
Storage set to gcd://duplicacy
Loaded 1 include/exclude pattern(s)
Parsing filter file /mnt/storage/pictures/.duplicacy/filters
Loaded 0 include/exclude pattern(s)
Restoring /mnt/storage/pictures to revision 502
Restored /mnt/storage/pictures to revision 502
Total running time: 00:00:04

And I know the file differs from the 502 revision as this is the output from the history command:

duplicacy history -r 502 -hash Organized/2018/05/2018-05-05_20-50-24-vid_20180505_125024.mp4
Storage set to gcd://duplicacy
    502:      1377447091 2018-05-05 21:50:24 9ab16847fdfb77b1bbb59bf1d3e5cb0dde7f5ca4128defd1495c3574b7990089 Organized/2018/05/2018-05-05_20-50-24-vid_20180505_125024.mp4
current:      1377447091 2018-05-05 21:50:24 e63033195b4516315a653940b843815b8cf86407e43cd36b8e241b327edc24e6 Organized/2018/05/2018-05-05_20-50-24-vid_20180505_125024.mp4*

EDIT: FWIW, I can restore successfully via the web UI

Have you tried the full pathname?

duplicacy restore -r 502 Organized/2018/05/2018-05-05_20-50-24-vid_20180505_125024.mp4

Probably should have mentioned that, but I did. Same result. No errors, just nothing restored.

Are you restoring over the original file? In which case, you’ll need to use the -overwrite option.

Or, you could rename the file out of the way and that should do the job, after which you can compare hashes.

-overwrite doesn’t do anything either. Just tried again to be sure :-/

That is probably because restore, like backup, detects file changes using the size and timestamp by default. Adding the -hash option should make it work.

So I think it has an issue to do with the file was read as a ‘bad file descriptor’. Completely removing the file allowed me to restore it.

Even with -hash it didn’t work. Very unusual.

I just tried this again with another file and I’m not getting any success even if I remove the old file.

Did you get any error message? If not, can you check the log file ~/.duplicacy-web/logs/duplicacy_web.log (assuming you’re running the web GUI) to see if there was any relevant message there?