Unraid: “permission denied” when attempting to launch duplicacy_linux_x64_2.7.2

I’m having an issue using duplicacy gui through unraid while trying to use backblaze as the storage.

I am getting the error message:

Failed to check the storage at b2://unraid-backblazeb2: fork/exec /app/.duplicacy-web/bin/duplicacy_linux_x64_2.7.2: permission denied

I am able to set up the backblaze storage initially, but after the docker gets restarted, I get the error message when trying to access the storage.

The only way I have found to fix it is to re-set up the storage by deleting the bucket and application key from backblaze and the storage from duplicacy.

I am also not getting prompted to enter the encrypted password, I only receive the error message.

Are you using custom docker image or one of the existing ones, if so — which one?

Have you configured user and group to have access to the mapped out folders, and are you running the container with that user? Post your docker run command.

Post logs from web ui and backup task.

This is OS level issue

So this would not matter.

thanks for the reply

I was able to fix the problem by running the command below in terminal in unraid

chmod +x /mnt/user/appdata/duplicacy/bin/duplicacy_linux_x64_2.7.2

i’m not sure why i would need to run the command though as it is a fresh install, but i added it to user scripts to run at start of array just in case it happens again

Which container are you using?

Normally this file is downloaded by duplciacy_web, unless it already exists in the config folder. Is it possible the -x was dropped by some external software?

If you delete the file the Web UI will download it again. Check if it sets correct attributes this time. This should tell you if the attributed was dropped later.

after doing some testing, i found that the x attribute gets taken off the file duplicacy_linux_x64_2.7.2 after some time

if i delete the file and restart the docker, here is the permissions that are set when downloaded again by duplicacy


and here are the permissions after some time, the permissions get set to something completely different


and here are the permissions after running the command in unraid terminal (chmod +x /mnt/user/appdata/duplicacy/bin/duplicacy_linux_x64_2.7.2)


i am running the hotio docker on unraid 6.9.2 - but i have also tried the other docker by “Selfhosters Unraid Discord Repository” and the same problem occurs

i also tried changing the UMASK setting from 002 to 000 in the docker - no luck

having to reset this permission anytime i would like to use the docker isnt a feasible solution

thanks for any help

This looks like unraid issue. Quick search of unraid appdata permissions at DuckDuckGo brings a bunch of reports by users about permissions magically changing, just like you describe.

I’m not familiar with unraid OS – but maybe you can enable auditing (similar to How to monitor permission, ownership or any other change to a particular directory or file - Red Hat Customer Portal) to find out when and why the flags change?

I think you’ll get better support on Unraid forums – since this is not duplciacy issue at this point.

I would also edit the title of this thread – it is not Backblaze issue either.

Ok thanks I will look into that information.

I’m not sure how to edit the title.

1 Like

I’ve run saspus/duplicacy-web on unraid for about a year without issue – 6.9, now 6.10.

The only tweak I made was to add DWE_PASSWORD as a Container Variable to bypass the login prompt.