Use SSH agent without prompting for private key


#1

I’m trying to backup using my SSH agent, but I get prompted to supply a path to an SSH private key each time: “Enter the path of the private key file”. I can’t supply a path, as my private key is encrypted.

I can just press enter to skip this prompt, and the backup works successfully (in other words, the SSH agent support does work fine). But I’ve been unable to figure out a way to set the preferences such that I stop getting prompted to provide an SSH private key filename. I tried adding “ssh_key_file”: “” to the preferences file, but it didn’t have any effect.


#2

Looking at the code it appears to be a bug. When the SSH agent is available (by checking SSH_AUTH_SOCK) it should just return the agent-enabled signer. But instead it continues to ask for a key file.

It also looks like there is a workaround. If you set “ssh_key_file” to an arbitrary non-empty value it will complain about not being able to open the key file but will return the agent-enabled signer instead of bailing out…


#3

I tried adding “ssh_key_file” to .duplicacy/preferences but it didn’t work.

I’m running Ubuntu and when I checked seahorse (“Passwords and Keys” from the dash) there is an ssh_key_file “password” listed for duplicacy. Adding an arbitrary non-empty value to that did work.