Validation error on -add command


#1

Please describe what you are doing to trigger the bug:
After initializing a local backup, I attempt to add a remote S3-compatible -copy with this command:

duplicacy add -encrypt -copy usbdrive dreamobjects serverfolders s3://us-east-1@storage-bucket.objects-us-east-1.dream.io

Please describe what you expect to happen (but doesn’t):
I expect the remote storage to be initialized, and the -copy job added to my backup configuration.

Please describe what actually happens (the wrong behaviour):
The operation fails, producing the following error:

Failed to download the configuration file from the storage: InvalidParameter: 1 validation error(s) found. - minimum field size of 1, HeadObjectInput.Bucket.

I have already opened an issue on github for this, so I am posting it in the forum in a childish plea for attention.


#2

This is likely a backend compatibility issue and not limited to the add command. Can you create a new local directory and initialize it with an empty directory in the storage? What storage service is this?


#3

dream.io looks like DreamHost’s “S3 compatible” cloud storage.


#4

@leerspace is correct, this is Dreamhost’s storage service. Dreamhost appears to redirect //storage_server.name/bucket to //bucket.storage_server.name by default. I didn’t have any luck trying the …/path/to/storage format, so I would guess that the default bucket address provided by Dreamhost might be causing the issue. I don’t understand how the code works, because my programming knowledge is virtually nonexistent.

Unfortunately, I won’t have access to the machine in question for the next week, so I can’t test anything until then.

Thanks for taking the time to think about this. I really appreciate it.


#5

I was finally able to use the machine again, and I tried initializing a new local directory with an empty directory in the remote storage, as you suggested.

I got the same error as a result.

Anything else I can try to get more information?


#6

Instead of s3://us-east-1@storage-bucket.objects-us-east-1.dream.io, did you try using the alternative storage url s3://us-east-1@objects-us-east-1.dream.io/storage-bucket?

The former is called the virtual-hosted–style url and the latter the path-style url (Working with Amazon S3 Buckets - Amazon Simple Storage Service). I’m not sure if Dreamhost supports both.


#7

The alternative url style worked this time. I was so sure that I had already tried that and gotten an error. I’m going to be very annoyed with myself if this was all because of a typo.

Thank you for your help.


#8

For anyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any #support topic: you can mark the post that solved your issue by ticking the image box under the post. That of course may include your own post :slight_smile:


#9

I spent some time looking for just such a checkbox. I couldn’t find it last week, and I can’t find it now. :confused:


#10

If you’re talking about the image then it’s all right u didn’t find it. it Appeard only in the #support category, and this is #bug!.

The other part about the heart button – that should be freely available everywhere with the exception that you cannot like your own posts