VSS Windows: Wrong volume snapshot

(Windows 10, Duplicacy 2.7.2)

I have a volume (Volume 3) mounted in a folder on the C drive (C:\Files).

When I run backup -vss, a shadow copy is created for the C volume (Volume 0), not for the C:\Files volume (Volume 3).

I tested it by running a long backup and accessing the shadow folder. The folder contained modifications I made to the files during the backup.

Please describe what you expect to happen (but doesn’t):
The shadow copy should be created for the correct volume (Volume 3)

1 Like

Can you backup Volume 3 directly instead of C:\Files? I don’t think it is a good idea to create a snapshot for each volume that is mounted under the source directory.

Hello Gilbert, thanks for looking into this.

I’m backing up a repository which resides on Volume 3 (C:\Files\repo-name).

When I run duplicacy backup -vss from that repo, I see the shadow copy created (C:\Files\repo-name\.duplicacy\shadow), but it is for the C volume.
I can modify files in the repo and see the changes in the shadow folder during the backup.

# duplicacy backup -vss
Storage set to c:\Temp\duplicacy
Last backup at revision 3 found
Creating a shadow copy for C:
Shadow copy {AF67E667-3BAF-4B9E-8E40-F2E5A81B8355} created
Indexing C:\Files[…]

What if there isn’t a corresponding driver letter for the volume? (Volumes can be mounted to a path instead of a drive letter under Windows.)

If creating a snapshot for every volume isn’t a good idea (agreed), what about if Duplicacy could look at the proper volume which the backup root is directly pointed at (e.g. C:\Files\ = Volume 3) instead of inferring from the drive letter.

1 Like

I didn’t know that you can mount a volume to a folder under Windows. So this is a bug and I’ll need to find the Windows API that can tell the volume from the directory.


Would it be this one?