Want finally delete snapshot from repository. How does that work?

I do have some snapshots in my repository which do not have any chunks. I now want to delete those snapshots finally. I read the guide, tried to prune the snapshots but it does not work. When I run check, I still get the empty snapshots listed for that repository.
Any help is highly appreciated.

I believe you have to run prune with the -exclusive flag on the last remaining revision of a snapshot, but even when that last revision is removed, there may be an empty snapshot directory on the storage (which will show up in check as an empty repository ID).

In either case, you can remove the snapshot folder manually on the storage and then run prune -exhaustive to clean up the remaining chunks.

2 Likes

Thanks - got it now. Had already run that prune job with the -exclusive flag.

Deleting the remaining empty folders on storage site did the job.

For anyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any #support topic: you can mark the post that solved your issue by ticking the :checked: under the post. That of course may include your own post :slight_smile:

1 Like