Wasabi us-east-2 region doesn't want to work with Duplicacy (GUI)

Wasabi recently launched their us-east-2 region, but it doesn’t seem to work with Duplicacy (or at least in the GUI). When I try to use us-east-2 I get the error, “Error: Failed to list the buckets: AuthorizationHeaderMalformed: The authorization header is malformed; the region ‘us-east-2’ is wrong; expecting ‘us-east-1’ status code: 400

This is what I received back from Wasabi support, “us-east-2 may be unavailable for some third-party apps and we are currently reaching out to the developers to look into this issue”.

They then recommended some other apps that currently work with us-east-2, however I’m already using the Duplicacy GUI for other backups and I’d really like to keep using it instead of having to use a separate client for a single backup.

Is Duplicacy already aware of this issue? If so, do you by chance have an ETA on when it might be resolved?

Here’s a screenshot of the settings I’m using within Duplicacy: https://i.imgur.com/uKdNsou.png (I also tried s3.us-east-2.wasabisys.com for the endpoint and it didn’t work either)

Based on your screenshot, you appear to be using the incorrect endpoint for the us-east-2 region.


Based on their documentation, the correct endpoint for us-east-2 would be s3.us-east-2.wasabisys.com.

I’ve tried both endpoints but neither work. I also tried us-west-1 and it didn’t work either. I then tried both us-east-2 and us-west-1 in restic and they both worked on the first try.

I just tested using a new bucket in us-east-2 and it works just fine with the endpoint from Wasabi’s documentation.

What’s the error you get when using these settings?


Wasabi has a major issue at the moment. See :-

for more details.

I have been using Wasabi for over 12 months without issues, and since last Saturday I have struggled to get a backup or status check successful on preconfigured system that has been working for the last 12 months. So it is very likely that a lot of your configuration attempts might be due to Wasabi issues and nothing to do with Duplicacy.

Having said that, while the problem is still open, I have been able to get some things working in the last 12 hours, so at least from my end I have the 1st sign since Saturday things are getting better.

Anyway, bear this in mind, and when I get a sec, I will post my working config for you.

Actually, I have no idea how I set this up originally, but pretty sure it was as per your original screen shot. What I do know is the that configure that Duplicacy uses and works today is :-


But it is worth noting a few things from my very rusty memory (that might not be 100% right) :-

  1. Region east has been around since at least Oct 18 and I have been using it successfully in anger since at least Nov 18

  2. Prior to that, there was a few hickups and changes in configuration at Duplicacy and Wasabi ends that did give some issues, but as far as I know all of that predates even the release of the Web GUI in Nov 18. You can read about some of the challenges here : Duplicacy and wasabi stopped working out of the blue . I suspect most of this is ancient history, but might give you some context which could be useful. But in that time there certainly was some compatibility issues between Wasabi and Duplicacy and differences between the regions.

  3. The current issue with Wasabi for me as resulted in VERY unreliable backups from the 5th to the 10th of October. When I look back, I did get some smaller backups through (lots of failures as well), but did not have a successful large backup in that time due to degraded performance. In addition, while I did not test it, if I needed to do a restore, I suspect it might not have been possible. And while I now seem to be able to get big backups through, and there are signs that performance is much better, the issue is still open and I yet might have more issues to come. Somewhat alarmingly they also had previous issues in Region West, and it looks suspiciously like whatever issues they had there, they did not learn the leasons and I am guessing that they made the same mistake with upgrades of region east, and that suggests that they might have some quality control and management issues in there. And all of this calls into question some of the very high reliability numbers they claim. So it does make me question if Wasabi is the right choice. Now I will continue to stick with Wasabi at this stage and see how it goes. But if this issue extends or becomes regular, I will have to rethink. I will persevere with Wasabi for 5 reasons. 1) price seem to be better than anything else on offer (at least that was the case 10 months ago when I finalised the decisions to go this way), 2) the speed was very good and better than even some more expensive offerings and I have generally been very happy with it once you tweak Duplicacy with the optimum number of threads 3) to date for me it has been reliable (ignoring that last week), 4) this is the 3rd string to my backup bow and while important, so far I assess that I would be pretty unlucky to have a Wasabi failure corresponding to a failure of my data AND my 1st 2 backup options, and 5) this is were I already have considerable amount of data uploaded so to change would be a pain. Anyway, if you are about to start with Wasabi, you might want to bear all of this in mind for your strategy.

I hope this helps.

1 Like

I can confirm that a newly created us-east-2 bucket works in Duplicacy if you set the end point to s3.us-east-2.wasabisys.com.

Wasabi is having trouble – my CLI-based backups and prunes have failed off and on over the last few days. Here’s Wasabi’s status page: