Web edition 1.5.3 doesn't start on login on MacOS

Please describe what you are doing to trigger the bug:
Set “Start on login” in Menu Bar dropdown.
Restart Mac and log in again.

Please describe what you expect to happen (but doesn’t):
Duplicacy restarts in background after restart and log in.

Please describe what actually happens (the wrong behaviour):
Nothing. Manual restart from the Applications folder required otherwise no backups happen.

Web Edition 1.5.3 as recently published by GChen
CLI duplicacy_osx_arm64_2.7.2 (Apple silicon M1 processor)
MacOS Big Sur 11.6.4

Cheers and keep up the good work

This is likely caused by the file ~/Library/LaunchAgents/duplicacy-web.plist still pointing to the old x64 executable file.

Run cat ~/Library/LaunchAgents/duplicacy-web.plist in terminal and check if it has <string>/Applications/Duplicacy Web Edition.app/Contents/MacOS/duplicacy_web_osx_x64</string>. If so, disable the Start on login and enable it again to have this file regenerated.

1 Like

That fixed it!
Thanks - I should have thought of disabling & re-enabling it:-)

I don’t use the Duplicacy menu bar “Start at login” option and instead have a separate Global Daemon that I run at MacOS load so that it has root access to backup all users on the computer. (Yes, there is a security trade off, but I’m OK with that :grinning:)

Anyhow… My Global Daemon has the correct path, but still refuses to actually launch Duplicacy at login. This same configuration (with different path) works fine with the 1.5 x64 build. It is strange that when logging in, macOS shows the daemon as running. If I unload & reload the service then it will launch successfully which implies the plist is correct. I’ll be doing some more troubleshooting to see if I can figure it out… but thought I’d share on this somewhat related thread.

Here is the content of the plist i use for the Global Daemon…

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
		<string>/Applications/Duplicacy Web Edition.app/Contents/MacOS/duplicacy_web_osx_arm64</string>

  1. The daemon must be in /Library/LaunchDaemons /
  2. Pass arguments to duplicacy:

Yes, there is a security trade off, but I’m OK with that :grinning:

If by trade off you mean all macOS security goes out of the window — then yes, maybe you can call that “trade off”

Edit: also, DWE_PASSWORD is no longer needed.