Web Edition - using non-standard HTTPS port

web-ui

#1

Please describe what you are doing to trigger the bug:
I configured the HTTPS settings to use a domain name, and also changed the default port to 445 (since I already have a website on 443)

Please describe what you expect to happen (but doesn’t):
I expected to be able to access Duplicacy web edition via https://(domain name):445

Please describe what actually happens (the wrong behaviour):
Duplicacy failed to restart and gives a pop-up with the error “can’t start web server: listen tcp: address 445: missing port in address”

It then attempts to open anyway using my configured domain name - however it uses port 443 which causes a certificate warning as it’s actually opening my other website which is on 443.

If I try to use the previous http://127.0.0.1:3875 address that immediately redirects to the HTTPS version but still using port 443.

This means I cannot access the Duplicacy control webpage at all now.

How can I remove the HTTPS settings to revert back to the way it was?

Thanks,
David


#2

I think you should go to ~/.duplicacy-web/duplicacy.json and delete the line about https and/or custom port.

note that i’m not using the web-gui, so this is only what i think the solution is.


#3

The configuration is in ~/.duplicacy-web/settings.json.

@zigzak try a different port. 445 didn’t work for me either but it other ports like 447 or 8080 worked.


#4

Excellent, I’ll try that thanks. Next question - where do I find folder ~? I’m on a Windows machine. Doesn’t seem to be in the root of my C: drive.


#5

~ means home folder (in linux, mac and windows – powershell), so that means generally C:/Users/[the user]/.duplicacy-web/


#7

Moving this to #support since it’s not a :d: bug. The issue with port 445 is that windows already uses it for smb.


#8

Learned something new, thanks! Found the file.
David


#10

I’m afraid that I’m still getting the same error - I’ve tried it with port 445, 447, 8080, and 8181?


#11

Try this:

    "listening_address": ":80",
    "https_address": ":8080",

The http port 80 needs to be open for Let’s Encrypt to perform the http-01 challenge.