WEB GUI auth failing

I receive fillowing error when I try to login “Failed to decrypt the testing data using the supplied password: cipher: message authentication failed”
I’m absolutely sure about password, it worked until two weeks ago,what can I do to solve it?

You can delete the encryption_data key in ~/.duplicacy-web/duplicacy.json. The web GUI will then ask you to set the encryption password again. It will take any password, but only if the new password is the same as the old password will the web GUI be able to decrypt storage credentials. Otherwise, you’ll have to remove all storages and recreate them using the same names.

thank you, i’m going to try it tomorrow… I will let you know if I solve

I’m sorry, it doesn’t work, when I enter the password (same as before) it shows following error
“Failed to save the new password: json: error calling MarshalJSON for type main.StorageCredentials: No master password provided”
If I try twice, it says that old password cannot be empty

version is 1.3.0 if it matter

You can try this workaround:

  1. Rename duplicacy.json to a different file like duplicacy.json.bak.
  2. Start the web GUI, enter the old password, and a new duplicacy.json will be created.
  3. Now copy the value of encryption_data in the new duplicacy.json to duplicacy.json.bak, rename duplicacy.json.bak back to duplicacy.json and then restart the web GUI.

But, 1.3.0 is too old. Current version is 1.5.0.

still no luck, here’s the logs after having followed your instructions…
2021/05/12 21:07:22 POST /verify_password
2021/05/12 21:07:22 Failed to apply the encryption key: cannot decrypt ssh_password
2021/05/12 21:07:22 Invalid password
2021/05/12 21:08:01 Skipping schedule backup UT at time 2021-0512 21:08 as no encryption password has been provided
2021/05/12 21:08:01 Please open the web browser at to enter the encryption password
2021/05/12 21:08:02 Schedule backup UT next run time: 2021-0513 21:08
Can I try something else? What about data remotely stored, can I still recover them?
I will upgrade at the end, I don’t want to add more work before having recovered entirely

This means the new password is different from the old one. What you can do now is to delete all storages and recreate them using the same names. You won’t need to do anything with the backups and schedules if you keep the same storage names.

Thanks gchen, i’m going to upgrade and restart…