Web GUI won't start on M1 Big Sur?

After blindly installing the Duplicacy container on my new Unraid setup, and then doing a bit of research on it I decided to try it out, and I’m sold. It was easy to set up on Unraid, and I decided to purchase for all of our household computers.

So far so good except for one thing… The web GUI won’t startup on my M1 Mac. Is it not supported? Or is there a different process on M1? I have Rosetta 2 installed and other Intel apps are working fine.

The app shows up as running in Activity Monitor, but the url doesn’t open up in the web browser if you type the URL in.

What am I missing?

What do you see in duplicacy_web.log? (somewhere under ~/.duplicacy_web) ?

Nothing, as it’s not there (but is there on my other macOS machines, so I’m sure I’m looking in the right place.

Just checked on my M1, works fine.

What happens if you start it in the terminal, e.g.

 % /Applications/Duplicacy\ Web\ Edition.app/Contents/MacOS/duplicacy_web_osx_x64

Do you see any complaints there?

I’ve waited about 10 minutes so far, and it just sits there. No complaints, but it isn’t doing anything.

(This time Activity Monitor shows a different application name, but the same 0% CPU, memory, etc.)

Hmm. interesting. can you do spindump on the process (you can do it from activity monitor), maybe you’ll see something relevant in the stackshots.

Are there any prompts in the System Preferences → Security & Privacy → General → Allow apps downloaded from.

Just in case, have you rebooted the Mac? Do you have any third party security software installed by a chance?

Ran the spindump, but nothing jumps out (though I’ve never looked at them before, so I’m winging it a bit).

No prompts, and the option to allow identified developers is selected.

I had forgotten about it, but CloudStike was installed as a part of a pilot I was running at work, and I just removed it and rebooted (for the 4th time tonight. :slight_smile: ). No joy. :frowning:

I’m starting to wonder if I’m having a problem with Rosetta 2, as I’m now remembering a similar issue I had a while back trying to run balenaEtcher while trying to create an SD card to run HomeAssistant. Moving to my Intel Mac ‘solved’ my problem. I’m going to try to uninstall Rosetta 2 and then reinstall it and see if that fixes anything. I have a couple of other Intel apps running fine though (Dropbox, OpenVPN client) so I’m not overly hopeful that this will help.

Ok, I’m not sure why this worked, but I was following the instructions here: How To Uninstall/Delete Rosetta 2 On M1 Apple Silicon Mac - YouTube and booted into recovery mode, disabled SIP (% csruril disable) and the rebooting seems to have resolved the issue (the web gui loads as expected).

It’s still working after re-enabling SIP (csrutil enable) so I’m guessing that something was corrupted somewhere, and this fixed it? I hate not knowing what was wrong, but I’m happy it’s working.

balenaEtcher isn’t working, but you can’t have everything…

1 Like

Weird. I don’t have an explanation either… On an intel Mac I would reset pram when some unexplained stuff would happen, but I’m not sure that is applicable to M1.

There are some bit sets in nvram that may be relevant – e.g. nvram csr-active-config and few others; you can see all of them with nvram -p. Clearing nvram should reset all accumulated crap in the configuration; but it’s a new Mac… there should not be anything legacy.

On the other hand you had some weird security software installed which might have messed with Mac security (to backdoor itself) and leave stuff in screwed way. csrutil enable or disable would set pre-defined known good configuration.

BTW make sure any kexts that CloudStike may have left behind are gone.