Duplicacy Web: "Failed to read the stat file for storage"

I initially thought this was a problem specific to my setup (Docker image on synology NAS), but after testing the windows version of duplicacy web, I noticed the same error in the log:

Failed to read the stat file for storage '[storage_name]': open C:\Users\[user]\.duplicacy-web/stats/storages/[storage_name].stats: The system cannot find the file specified.

As a result, the “storage size” dashboard always shows 0 bytes backed up.

Is this a known issue?

Thanks in advance,
Gabriele

You need to schedule and run a check job for that storage. The .stats file will be created after the storage has been checked.

Hi,

I’ve recently installed Duplicacy Web in Docker using this https://hub.docker.com/r/saspus/duplicacy-web by saspus, however it is deployed on a Synology DS918+ NAS.

Everything seems to work quite well (tested backups/restores etc) via cloud storage and local and it works as designed, however I am noticing in the logs that the stats cannot be loaded, as this file path doesn’t exist in the NAS:

Failed to read the stat file for storage ‘storage-name’: open /root/.duplicacy-web/stats/storages/‘storage name’.stats: no such file or directory

Manually navigating to that directory does prove it doesn’t exist, (ls while SSH’d into the NAS and sudo) but it seems I am unable to change the behaviour of the image by mounting the volume of where the stats folder is actually located when I created the docker image. In my case is:

/volume1/docker/duplicacy-web/config/stats

All the relevant folders that it seems to need are there, I just can’t figure out how to remap the file paths in the image to where the folders are located in my case.

I don’t know whether this is a Synology NAS Docker limitation, or if I’m just doing something wrong…

Any help would be appreciated. Thanks

1 Like

+1 on the question by evakq8r91, I am seeing the exact same problem (docker image by saspus on Synology DS1515+ running DSM 6.2.2-24922).

One thing I noticed is that Docker GUI on DSM doesn’t allow to pass (to the best of my knowledge) the "-h " option. I wonder if that may be the reason (since it seems to default to “localhost” in that case)?

Any help appreciated!

Gabriele

That solved the problem. Thanks!

1 Like

Also confirmed working for me as well. Thanks very much - glad it was that simple.