Invalid or Expired License - Sudden Error Message

Hi, I’ve been using the web-ui for a while now, and I applied a paid license to it a couple of months ago.

Suddenly my scheduled backups are failing with the error “Invalid or Expired License”.

However, when I click the “Personal” link in the backup section to check my license it confirms I have a valid license: 21
“This computer is running with a personal license that will expire on 2021-01-19”

I searched for this in the forums and found a macos terminal command to run, but that doesn’t work either:
defaults delete com.acrosync.mac.duplicacy License
2019-03-22 07:17:46.800 defaults[4355:1776078]
Domain (com.acrosync.mac.duplicacy) not found.
Defaults have not been changed.

What can I do to fix this?

1 Like

The saga continues. I quit and restarted the app, now it’s telling me “This computer is running with a trial license that has already expired.”

When I try to apply my license key from the customer portal, it gives me the error message “Failed to download the license: License error: Activation code has already been assigned to host localhost. Please log in to your Duplicacy customer page to change the host”

What do I do?

Go to Log in required and click on the link that says localhost under the Host column. Then you can change it to the host name of your computer.

1 Like

Hmmm, the problem came back for me when I upgraded to the WebUI v1.

I verified that my hostname matches what’s in the customer portal, but Duplicacy still says trial. When I try to paste in the key, it says it’s already being used by my hostname.

Just to make sure I’m not out in left field, I check my hostname (MacOS) by going to:
System Preferences > Sharing


1 Like

The host name seen by Duplicacy is different from that on your customer page.

I’ll message you the correct one.

How would one find the host name as seen by Duplicacy?

I’ve tried all of the following from a shell:

scutil --get HostName
scutil --get LocalHostName
scutil --get ComputerName

All but the last provide the same string. I’ve tried updating the host in the license with each of them, but I still get the Invalid or Expired License message.


Please disregard my question above.

I found that the problem was the issue described in:
"Invalid or expired license" failure on MacOS update.

I now have backups working.

And, to answer my own question, the host name that worked was the one returned by the first four of the commands I listed above:

scutil --get HostName
scutil --get LocalHostName


1 Like

exact the same issue here as from described joe.

Why does Duplicacy suddenly change my computers name? It hapennend now 4 times. Can somebody from the develop explain or better please solve this?

Duplicacy does not change computer name. Your computer name depends on many factors, and can change depending on network configuration. Therefore using the hostname name as a basis for license verification is a problem here.

this was brought up before: Invalid or expired Web-UI license after reboot (Backups were working fine earlier today, and my license is valid well into 2022) - #9 by saspus

Guys I’m losing my mind! It’s always the same. Please change that licencing system! It keeps going. Some day Duplicacy says my licence is expired, because Duplicacy says my computers name is now XXX-Macbook-Pro instead of XXX-MBP and vice versa. So I’m interested in any details. Thats your job. I paid for this Software. And in the end it’s just a bad implemented code. All other software in the world has no such problem with their licencing mechanism.

1 Like

This can happen if you activate the same license code on multiple computers. Each computer needs to have its own license code.

WTF? What do you people think who I am? For sure I did not activate the same license on different computers! It just your buggy software! If you read carefully then would have noticed that I did not activate on different machines.

1 Like

If the host name switches between XXX-Macbook-Pro and XXX-MBP then it is probably caused by different networks assigning different host names. However, the server log shows that sometimes your host name had the form of Desktop-xxxx which is more likely a Windows machine.

It goes on and on! What an ignorant development team! There are so many licensing models in the world that work fine. It’s not the customers’ fault. Look at your board. It’s full of these problems. You are selling an immature product.