No previous revisions found

wasabi
fixed

#1

Hi Guys,

I just purchased your software for use with Wasabi after you guys got a pretty good reputation on Reddit.

After waiting 3 days for my data to upload to Wasabi, I went to complete a restoration test to ensure everything worked OK.

When I go into the restore UI, no previous revisions of the backup are found. However, I can run a backup over the top and it completes with no problems. I’ve tried to run the backup a few times, and it appears to complete totally fine.

The logs look like this when I re-run

2018-01-17 19:56:22.487 INFO STORAGE_SET Storage set to s3://us-east-1@s3.wasabisys.com/nasbackup//
2018-01-17 19:56:24.303 INFO BACKUP_START No previous backup found
2018-01-17 19:56:24.303 INFO BACKUP_INDEXING Indexing D:\ServerFolders
2018-01-17 19:56:24.303 INFO SNAPSHOT_FILTER Loaded 7 include/exclude pattern(s)
2018-01-17 19:56:24.740 INFO BACKUP_LIST Listing all chunks
2018-01-17 19:56:24.992 INFO BACKUP_THREADS Use 4 uploading threads

---- CLIPPED
2018-01-17 21:55:54.675 INFO UPLOAD_PROGRESS Skipped chunk 63548 size 2374476, 43.41MB/s 00:00:01 99.9%
2018-01-17 21:55:54.682 INFO PACK_END Packed Users/Meg/Backup of Backup/unknown zoo trip/DSC_0204.NEF (18046602)
2018-01-17 21:55:54.798 INFO UPLOAD_PROGRESS Skipped chunk 63549 size 5529693, 43.41MB/s 00:00:01 99.9%
2018-01-17 21:55:55.003 INFO UPLOAD_PROGRESS Skipped chunk 63550 size 14714800, 43.41MB/s 00:00:01 100.0%
2018-01-17 21:56:04.669 INFO BACKUP_END Backup for D:\ServerFolders at revision 1 completed
2018-01-17 21:56:04.669 INFO BACKUP_STATS Files: 48369 total, 311,284M bytes; 48369 new, 311,284M bytes
2018-01-17 21:56:04.669 INFO BACKUP_STATS File chunks: 63550 total, 311,284M bytes; 5 new, 36,869K bytes, 36,213K bytes uploaded
2018-01-17 21:56:04.669 INFO BACKUP_STATS Metadata chunks: 4 total, 18,096K bytes; 3 new, 17,743K bytes, 8,046K bytes uploaded
2018-01-17 21:56:04.669 INFO BACKUP_STATS All chunks: 63554 total, 311,302M bytes; 8 new, 54,613K bytes, 44,260K bytes uploaded
2018-01-17 21:56:04.669 INFO BACKUP_STATS Total running time: 01:59:40

But then when I go to restore, I get no revisions found. Can you please assist? I’m hoping I’ve just missed something simple or this is a quick bug you can help resolve.


#2

Actually - I may have just realised the problem.

My bucket was configured with an extra trailing / for the directory after the bucket name.

I edited the preferences file to remove the trailing / and now it appears ok… I’m going to keep testing to make sure that’s it and backups/restores work correctly. Might be a bug with the UI form that it’s able to add a trailing / without validation?

Cheers
Harrison


#3

This seems to have been fixed in the beta of version 2.1.0 (available from Version 2.1.0 beta is available for testing). I tested with an extra / at the end and it does show the revisions and restore correctly.