Version 2.1.0 beta is available for testing


#1

https://acrosync.com/duplicacy/duplicacy_gui_osx_2.1.0.dmg

You can now schedule multiple backup jobs with this version. The restore dialog has been overhauled to provide a better experience. Although this is a beta version, the backup and restore operations are carried out by the CLI version as before so if there is any issue it will likely be a GUI issue and won’t cause any catastrophic errors.

I hope to roll out the windows version tomorrow.


Unsupported encryption version 1
License reset for 30-day trial
Error when connecting GUI to B2 Bucket created with CLI
Duplicacy waking windows from sleep
Configure for multiple storages
Restore (list files) takes too long
No previous revisions found
#2

Windows versions are finally available too:

https://acrosync.com/duplicacy/duplicacy_installer_win64_2.1.0.exe
https://acrosync.com/duplicacy/duplicacy_installer_win32_2.1.0.exe


#3

What’s the suggested way to use this with an already installed 2.0.9 version (on Windows)?

Uninstall the old version first or simply install the new one over the existing one?
Also will this just work with the existing repository or should we setup the repository/storages from scratch (iirc you changed the nested folder structure in some situations in this update)?


#4

You can just run the new installer to overwrite the current installation, unless you installed the service in which case you need to stop the service first.

The new version will work with any existing repository/storage and respect the current nested folder structure initialized by earlier versions. Only if you run the new version to initialize a new storage will the new nested structure be used.


#5

I’m not able to install this until tonight so I apologize, but I’m a little confused by the version naming between CLI and GUI. I’m really looking forward to trying this version!

The latest CLI version is 2.0.10, is this different from GUI version 2.1.0 (beta)?

Which CLI executable version does the 2.1.0 beta call?


#6

Hello, I can not get this version to work with repositories with multiple backup destination storage. Does this version suppose to support repositories with multiple backup destinations?


#7

I upgraded from 2.0.9.

Issue 1

Seeing an issue with renaming of the jobs, does not seem to take effect after renaming.
It updates to the correct thing once I “start” the job but it doesn’t after I close the dialog rename box.

Issue 2

When making a SFTP server, I seem to get a authentication error even though it is successfull.
I took a look and on the first handshake it makes the correct files to initialize a new repository, and it backs up successfully.
The error window made me think that it didn’t work.

Issue 3

Testing out restoring, and I can’t get it to list any files.
I just made a SFTP backup, ran the backup three times in a row, and none of them list any contents.
The files on the server are 25.2mb and 27.7mb on disk in windows.

Comments / Feedback

  • Would also be nice if the jobs had default place holder names, was confusing at first. Maybe “Job #1” etc would be clearer.
  • A plus button next to the last tab would make it quicker and more apparent that one can add multiple “jobs”. Could still keep a right click, but is more intuitive if you had a dedicated button for it.
  • Would be nice to be able to specify the ssh port for the SFTP server, don’t see where to do that

#8

@ws, there isn’t a CLI 2.1.0 yet. I’ll release it once the GUI 2.1.0 is out of beta. Currently the CLI version that the GUI calls is just the latest on the github master branch. If you don’t want to build the binary from github, you can find it under the directory where the GUI version is installed (on macOS it is usually under /Applications/Duplicacy.app/Contents/Resources/, and on Windows it is in the same directory as the GUI executable).

@maccra, this version does not support multiple storages within the same repository. I’m planning a web-based version that will support all CLI operations (like copy, check, prune).

@goldbattle, your bug report is super helpful! I’ll fix all of them in beta 2. As for the SFTP port, you can specify the server in the form of address:port.


#9

Thanks for the clarification!


#10

this version does not support multiple storages within the same repository.

Hm, wasn’t that what everybody was waiting for?


#11

I have tried to initialise a new storage in OneDrive and on a 3rd Party SFTP server. In both cases I get a similar message as mention by @goldbattle in Issue 2 and in both cases it was successful. However it only works when not encrypting the storage. When I tried to wanted to setup an encrypted storage it failed.

Win10 x64 Pro


#12

A new beta build for both macOS and Windows has been uploaded which should fix all issues reported by @goldbattle and @maccra. You can download them using the same links given above, and after installation the window title should say Beta 2.

@Christoph, sorry if I mislead you, but this update is mainly about multiple repository support to allow more than one repository to be configured in the GUI version. This is the most requested feature. Our next major update will switch to a web-based UI which will support all CLI operations as well as multiple storages in one repository.


Can't restore my broken external harddrive
#13

this update is mainly about multiple repository support to allow more than one repository to be configured in the GUI version.

Sorry, had the two confused for a moment. But I can find support for multiple repositories in the current beta either…

By “web-based GUI”, do you mean duplicacy will be running its own web-server locally?


#14

If you right click the system tray icon or the tabs of the configuration window you’ll see the menu to create new jobs.

Yes, we plan to work on a new GUI version that has a built-in web server and users can manage the backups or run other commands by connecting to the web server using a browser.


#15

I had “add a job” working previously (click “add a job”, a new tab shows up the top of the GUI to configure, etc), but I’ve since reloaded the machine. Now when I click “add a job”, nothing happens; no new tab.

EDIT:
I believe I was on B2 previously, and now I’m on B3.


#16

The “add a job” menu from the tray icon has a bug so it doesn’t add a job when you select it, but the same menu from right clicking the job tabs should work.

I uploaded beta 4 that fixed this bug. It can be downloaded from the links given above.


#17

Works like a champ after upgrading to B4. Thank you.


#18

It seems to me as the “Restore to” option is missing in the restore dialog?


#19

It seems to me as the “Restore to” option is missing in the restore dialog?

Right. This is now more inline with how it is done in the CLI version. To restore to a different directory, you can create a new repository from that directory and then select the original repository id from the dropdown list in the storage password dialog.


#20

Ah…got it, thanks for the clarification.

From a user-convenience-perspective i’d suggest the following for the ‘Storage Setup’ Dialog:
Besides the different backend options also offer the option to pick one of the previously defined storage backends. (In my case looking at the screenshot above: Offer me the backend-storage settings from “This Job”).

That way the user doesn’t need to re-enter already setup credentials (for example when restoring files to a different folder/repository).