Sporadic failures backing up from OneDrive folder

on my PC at some point one of the Windows 11 upgrades has moved my ‘local’ documents into OneDrive…i’m not super bothered either way, but i now get sporadic failures from Duplicacy trying to backup ‘cloud’ files that aren’t actually available locally. When it fails it logs this and then stops

ERROR CHUNK_MAKER Failed to read 0 bytes: read \\?\C:\Users\me\OneDrive\Documents\something: Access to the cloud file is denied.

When it succeeds it logs a warning instead and skips the file:

2024-01-03 10:39:47.155 WARN OPEN_FAILURE Failed to open file for reading: open \\?\C:\Users\me\OneDrive\Documents\something: Access to the cloud file is denied.

I don’t mind if it doesn’t backup files that aren’t actually on the local disk, but I don’t want it failing the entire backup, so the ‘WARN’ behaviour is preferable.

You probably want to exclude the OneDrive folder (by adding a filter like -OneDrive/*). There is no need to back up these files.

i do want those files backed up though, i don’t want to just rely on OneDrive. as i said, all my documents etc have been moved into a ‘onedrive’ sync’d folder.

I haven’t used windows for a very long time but in the past I remember that if you don’t tell OneDrive to sync all files (as opposed to fetching them on demand) then it will create a fancy directory junction that duplicacy does not support parsing. If you do sync all files — then onedrive stashes everything into a simple folder.

Very few backup tools support backing up cloud-only files. Support for dataless files

yeah…there is a setting to download everything, which i’m trying to avoid. i guess i’m not being very clear here:

  • i would like files that are in fact on the local disk to be backed up
  • i do not care if ‘cloud’ files are not backed up

this is, in fact, how duplicacy works most of the time (it logs those warnings in the second snippet in the OP). sometimes, it fails with the error in the first snippet, and then the whole backup fails. i would just like it not to ‘fail’ as it does in the first snippet.

I added a workaround: