Duplicacy Web Edition 0.2.10 Beta is now available

web-ui

#15

Right. It will be in version 1.1.

This is a bug but I won’t fix it because it only affects users from beta 1 (which allows you to create schedules without a name).


#16

Multiple host support is planned for version 1.1.


#17

I’m running it on a remote headless server. I’ve tried opening the web interface from the command line using Links, but it doesn’t work.

Can I edit a configuration file to do this? There are a set of files under ~/.duplicacy-web created by the last beta that did listen on all addresses.


#18

I’m using windows 10 pro.
I can confirm that it still happens and it’s very annoying. bc the command prompt appears once per job and gets on top of everything else.

The only thing that changed is that before I had beta 0.1 exe placed in the same directory ("\Users\user.duplicacy-web") and for 0.2 the setup created the exe in %appdata%
Could that be it?

Please help me debug this @gchen .

hehe I knew it.

as soon as I saw your implementation. :slightly_smiling_face:

Any chance we get API endpoints for multiple host support? :pray:


#19

1-For each operation the CLI runs in a new command window in the foreground.
New window per concurrent operation. This did not happen before.
Could we change it, please?.

I don’t see this problem when testing on Windows 10. Which version of Windows are you running? Anyone else have this problem?

I have this problem too, Windows 10 1803
It looks like this: https://imgur.com/a/qlYxBVT and https://imgur.com/a/5Upxx3o

Also in beta 0.1 and now in beta 0.2 I noticed strange behavior with purge command.
If I run it once, I get “Prune in progress” https://imgur.com/a/Jpl6iRz
If I run it again I get “Completed” https://imgur.com/a/YwMnGaA
If I run it again I get “Prune in progress” https://imgur.com/a/dH5LXIn
If I run it again I get “Completed” https://imgur.com/a/Pe91fBr
and so on …
So if I want to purge, I had to start it twice
Log in .duplicacy-web\logs is created only if status is “Completed”

Nothing interesting in purge log:

Running prune command from C:\Users\user.duplicacy-web/repositories/localhost/all
Options: [-log prune -storage Appdata_disk_J -keep 0:1800 -keep 2:60 -keep 1:37 -dry-run -id users_appdatabeta]
2018-12-15 10:50:01.194 INFO STORAGE_SET Storage set to J:\Duplicacy_2018_cil\BETA\Appdata_duplicacy_cil
2018-12-15 10:50:01.197 INFO RETENTION_POLICY Keep no snapshots older than 1800 days
2018-12-15 10:50:01.197 INFO RETENTION_POLICY Keep 1 snapshot every 2 day(s) if older than 60 day(s)
2018-12-15 10:50:01.197 INFO RETENTION_POLICY Keep 1 snapshot every 1 day(s) if older than 37 day(s)
2018-12-15 10:50:01.410 INFO SNAPSHOT_NONE No snapshot to delete

#20

If you set the following in your home directory in ~/.duplicacy-web/settings.json, it’ll set the listening address to all interfaces on port 8080:

{
    "listening_address": "0.0.0.0:8080"
}

edit: removing the errant comma as identified by @AnthonyCartmell further down. I had copy/pasted my settings.json and removed a couple of the lines without removing the now-unnecessary comma.


How to access the duplicacy web-interface remotely
#21

Exactly. Good to know I’m not the only one. I was going crazy.


#22

The Add include/exclude patterns dialogue box (Backups > Include/Exclude link > Add...) cannot be canceled out of. The Cancel and x buttons don’t seem to do anything. The only way I can see to close it is to click ok.


#23

Another little bug:
Setting up password for first time do nothing if I click “Set” button
Tested on IE11 on Windows Server 2016/2019
(IE Enhanced Security Configuration was set OFF)
console error message in screenshot
https://imgur.com/a/69bpndF

In Firefox ESR 60.3 it works without problem.


How to share images and screenshots (just copy and paste!)
split this topic #24

3 posts were split to a new topic: How to share images and screenshots


#25

I’ll take a look at this.

If you don’t enter anything in the Directory input box before clicking on the browsing button, does remote directory listing start from your home directory or from the root? (It should start from your home directory).


Chunk uploading error with Synology
#26

Just wanted to add, I know some of this has been mentioned.

  1. Please do not use port 8080 :slight_smile: I immediately saw that and thought it would be an issue. Pick anything (someone said 3875 I think? or just 18080 or 9080, like I use on projects). I don’t see why, if this is an app, as opposed to a web server, you would need to use a common port like 8080. Since this be changed in config, we could always set what we prefer, but the default should be something non-standard and uncommon.
  2. Creation of backup job should allow use of CLI settings files, particularly filter files. OR, have an option to import job settings from CLI. In fact, if I pick a directory location to backup and there’s already a .duplicacy folder, the GUI should use those settings by default. Even if its only as a one time import. (when I say settings, I’m really interested in filters more than anything because of the time spent tweaking them)

Nice job on this! I like it!


#27

Perfect, thank you. Created ~/.duplicacy-web/settings.json and added that (less the trailing comma) and it works nicely!


#28

Another feature request:)
Can we have please remaining time for “Copy” operation like is there for “Backup”?

This is how “Backup” looks like:
image

And how “Copy” looks like:
image


#29

I’ve uploaded a new beta with version number 0.2.1. Most bugs reported so far have been fixed.

The download links and changes can be found in the first post.


#30

I’ll push back this feature to version 1.1.


#31

I’m having a problem with the “Storages” page. When I click on it, I just get a blank white page. I’ve tried Firefox and Chromium, Windows and Linux, and it doesn’t work on either. I’m not sure if it matters, but my Backblaze bucket name has a - in it. Let me know if there’s any more info you need to help pin this down.


split this topic #32

3 posts were split to a new topic: Chunk uploading error with Synology


#33

The only thing I’ve noticed in 0.2.1 is a very minor UI issue on some clickable elements. While most UI elements that are clickable change the cursor appropriately (to a pointer style) when hovered over by the mouse to indicate that they are clickable, there are at least 6 places where the mouse does not change and it’s not as clear something can be clicked.

  1. Backups page > last backup status (e.g., “Completed last hour”)
  2. Backups page > Trial (license link)
  3. Schedules page > Parallel checkbox
  4. Schedules page > Options column
  5. Schedules page > Status column
  6. Schedules page > Send email after completion checkbox

An example of a link that changes the cursor style as expected is the Backups > Include/Exclude column.


#34

If we should report minor issues: :slight_smile:
1.) In Firefox (not in anonymous window) every time I’m on http://127.0.0.1:3875/settings and leave, for example clicking on SCHEDULES, popup from Firefox ask for saving password
(maybe because password **************** is pre-filled)

2.) I somehow managed to create localhost-1 to 5 in activities, no data in any of them.
On another machine I have only localhost-0 and 1. I cant see any localhost records in .duplicacy-web\stats\schedules
image

3.)
I remember that from the beginning I was little confused by that arrow, I thought it suggested wrapping the left panel, but not.
image

4.) It would be nice if we could somehow run check without creating dedicated schedule task for him. For example if we could run check from STORAGES tab. Or even better - if we could somehow run only selected task from schedule.