Duplicacy Web Edition 0.2.10 Beta is now available

web-ui

#63

Here’s the log from a computer that has the issue. Let me know if there’s anything else you need from me.
duplicacy_web-Squidward.txt (782.4 KB)


#64

I’m noticing a few bugs with the current version.

In the Temporary directory and Log directory settings fields on Windows 10, It has a mixture of forward and back slashes. For example, it reads C:\Users\Username/.duplicacy-web/repositories but when choosing a directory in the Web panel, it rewrites them to be forward slashes. Second bug is in the same area, if I try to choose the .duplicacy-web folder, it doesn’t appear since the app sees it as a hidden folder.

When configuring storage, an options reads Copy-compatiable with instead of Copy-compatible with

I also notice an error with the options field for the Backups tab. I tried adding -verbose or -v but both come back with the error Invalid options

Running backup command from C:\Users\User/.duplicacy-web/repositories/localhost/0 to back up C:/ Options: [-log backup -storage GDrive -vss -verbose -stats] Incorrect Usage.

When on the restore process, if I click on the folder selector for the restore to field, it opens up behind the main restore window instead of in front.


#65

@gchen Thanks for the new version, restoring works now :slight_smile:


#66

@simon can you check your log to find a line that says “path xxx is a file”? It looks like you have a directory that is also a file at the same time and this caused the Storage page to fail in previous versions.


#67

I uploaded the links in the first post to point to the latest 0.2.4 build. Most bugs founded in 0.2.1 should have been fixed in 0.2.4.


#68

I just tried 0.2.4, and I can confirm the Storages page is working for me now. Thanks.


#69

I notice a new bug with 0.2.4, with schedules. I have one schedule with 4 backups configured (different ids) to run in parallel. In the GUI though, only the last drive shows status while the first 3 have no status even though there’s 4 processes of duplicacy running.

If I disable them to run in parallel and start the schedule, it works sequentially like normal.


#70

@gchen the log says The path docker-hosts was a file and in that path there is also a file named docker-hosts. Was it that why it crashed before?


#71

The latest beta version is now 0.2.5. @camjac521 this new version should fix the parallel job execution bug you found.


#72

Yes. Anything special about this file? Why is it also a directory for other files?


#73

Awesome, thank you.

Would it be possible to be able to see the status synced up from the schedule tab to the backups? When you run the schedule, the backups tab doesn’t show the same status.

Also, is it possible to change the verbosity of the logs in maybe the settings and an option to enable (so it can be disabled) opening the web page on startup?

I also had a question since it confused me a bit. What’s the difference between the encryption password you set when the app is launched for the first time versus the Storage (Gdrive in my case) password that is optional.


#74

I found problem with exclude filters when Backup folder os root drive on Windows(D:\ for example)
When I click Include or Exclude, first letter is cut off.
I was able to replicate on another Windows computer.
(sorry camjac521 - I replied to your post by accident :slight_smile: )

Edit: another thing:
I set up copy job do Webdav on Synology, for some reason there is some problem, check is reporting Missing Chunks

But storage page is reporting all OK - All referenced chunks exist


So storage reporting works only for backup jobs?


#75

I’m experiencing another issue. I have two schedules listed, one that is supposed to occur every hour, and one that is supposed to run daily. The hourly is supposed to be a backup job, while the daily schedule is a check. The problem I’m having is that the hourly schedule is triggering the daily check job instead of the correct backup job. If I delete the daily schedule, the backup runs as it should. This is occurring on both Linux and Windows. I’ve tried 0.2.5 on Linux and I’m having this problem, but I think the Windows computer I tested is still running 0.2.4. Attached is a screenshot of my schedules. The backup was set to every 15 minutes for testing purposes.


#76

@jnapoli @Flibble I updated the first post with links to version 0.2.6 which should fix the two bugs you found.


#77

Everything seems to be working. Thanks for such a quick fix. I’ll let you know if I come across any other problems.


#78

@gchen Thanks
Today I noticed I have problem switching between “Storage” on restore page.

When I select Storage, then backup IDs stay same. So I’m able to restore only from first storage in the list.

And behavior is different in Chrome and in Firefox.
In chrome I can not restore from another storage at all.
In Firefox if I select another storage, backup IDs don’t refresh, but I can press F5
After F5 storage in FF stay same and I can see Backup IDs

Wrong backup IDs in Chrome:
image

Right backup ID in Firefox after pressing F5
image

(I did test it after deleting .duplicacy-web folder and starting from scratch)


#79

@Flibble this has been fixed in 0.2.7 (links in the first post).


#80

Thanks for fast fix, I can confirm that it’s fixed :slightly_smiling_face:


#81

Hello,

I use the -vss option to do my baclup on windows. So I have to launch duplicacy_web_win_x64_0.2.7.exe as an admin. This is working, when I launch manualy Duplicacy.
My problem is that I would like to launch automaticaly duplicacy web edition at the beginning of my session. And I don’t know how to do that… If I check the option “start on login”, this isn’t working as not launch as admin…

How can I do ?


#82

The way I do it, with GUI v1, is to set up a task with Task Scheduler - you tick ‘Run with highest privileges’ option and set the trigger action to ‘At log on’. This works, but I hope GUI v2 will eventually make this easier, perhaps by driving everything through a service.