Duplicacy Web Edition 0.2.10 Beta is now available

web-ui

#42

If you click Don't save does it keep showing the dialog next time? Any other options from the pull down menu?

localhost-* are for manually run backups. You’ll see activities on those rows after you start running the backups directory from the Backups page.

If there is a good solution that doesn’t interfere with regular schedules, I’ll implement it.


#43

I’m not sure if this has been asked, but when I try to restore a backup from a storage with multiple id’s I get “Failed to list files: Error: Network Error” and duplicacy shuts down. It works fine restoring from the command line.


#44

For Linux you can just run the downloaded executables. No installation is required.

If you want to run it as a service (to make it start automatically on startup) – that depends on the Linux distribution, but I think the instructions on this page should work most of the times: How to run a Linux Program on Startup – Tim Leland


#45

I’ve fixed all these in my code base.


#46

I have some new information about the Storages page. Last night, I installed the Web Edition on one of my other computers. The Storages page worked fine until I ran the first check on my storage. After I did that, I am having the same problem. On that computer I used Edge, since that is the browser that happened to pop up when I opened Duplicacy.


#47

If I click don’t save its keep showing next time, I have to select “Never Save”
(but then Firefox stops ask to save password for all 127.0.0.1 websites (on all ports) )
image
It’s really not important, just for information.


#48

Can you check the log ~/.duplicacy-web/logs/duplicacy-web.log to see if there is any error message?


#49

Can’t see any error messages. Here’s the log output when I try to list files.

2018/12/18 21:17:30 127.0.0.1:51457 POST /list_files
2018/12/18 21:17:30 Created listing session grzjn
2018/12/18 21:17:30 Running C:\Users\test/.duplicacy-web/bin/duplicacy_win_x64_2.1.2.exe [-log list -r 1 -storage ext-hdd -files]
2018/12/18 21:17:30 Set current working directory to C:\Users\test/.duplicacy-web/repositories/localhost/all
2018/12/18 21:17:31 INFO STORAGE_SET Storage set to E:/backup/duplicacy
2018/12/18 21:17:31 INFO SNAPSHOT_INFO Snapshot backup revision 1 created at 2018-12-18 19:16 -hash
2018/12/18 21:17:31 Total files: 36728

#50

I have this version set up with storage on remote server via sftp , and seems to be working well so far! A few pieces of feedback:

  1. Under “Schedules”, if I create a new job block, add a couple of jobs, then immediately remove those jobs so that the job block is once again empty, I am unable to delete the job block (the X is greyed out).
  2. The “restore” function is very hard to find…all I see is a small icon in the upper right of the “Storages” tab.

#52

I have the same issue. As a workaround i setup a ssh tunnel on my client machine

ssh -l 8888:127.0.0.1:3875 “your-server-address”

then point your browser to http://127.0.0.1:8888 and use the webinterface to listen to 0.0.0.0:3875 as leerspace suggested.


#53

@rrovetti I was tricked by that delete button too:) That delete buton is only for jobs. If you want delete block, you have to click on “clock” schedule button and “delete schedule”.
image
image


#54

Hi all,

  1. I am agree with “Restore to” but is absolutely necessary a check box with “Restore to the same location” and the ability to overwrite the restored file or folder.
    Now if I set to “Restore to” the same folder where the file is, it creates a new folder with the same name inside and there restore the file. What does the “Options” field in this case if I cannot set “-overwrite” .

  2. We should be able to select more files to restore from a folder, now it is possible to select only one.

Thank you.


split this topic #55

A post was split to a new topic: SMB storage input/output error


#56

@simon @jnapoli can you try this version: https://acrosync.com/duplicacy-web/duplicacy_web_installer_win64_0.2.2.exe?

This version will produce more information in the log to help debug the issues you encountered.


#57

I’m not sure if it’s a regression in 0.2.2 or a windows issue (since I haven’t tested 0.2.1 on windows), but clicking on the Parallel and Options columns on the Schedules page in this version doesn’t do anything. No errors are logged to the console and a browser navigation to the schedules page happens, but the two columns do not function (i.e., parallel toggle doesn’t change or show confirmation, and the options window doesn’t open).


#58

Yes, this is a new bug caused by the cursor style fix. Please test 0.2.1 only at this time as 0.2.2 was a temporary release for debugging only.


#59

I think I found not ideal behavior.
If I rename source backup folder and run backup schedule, “Status” is still green “Completed”
Even if in backup log is:

WARN LIST_FAILURE Failed to list subdirectory: open C:\Folder: The system cannot find the file specified.
WARN SKIP_DIRECTORY Subdirectory cannot be listed
BACKUP_STATS Files: 0 total, 0 bytes; 0 new, 0 bytes
Running script C:\Users\user.duplicacy-web\repositories\localhost\5.duplicacy\scripts/post-backup.bat

And post-backup script is started.

Expected behavior is that backup is maybe “Failed” for backup job - like for example when backup destination is not accessible.


#60

Here’s the debug log:

2018/12/19 22:25:56 Total files: 36728
2018/12/19 22:25:56 An error has occurred: runtime error: invalid memory address or nil pointer dereference
2018/12/19 22:25:56 goroutine 109 [running]:
runtime/debug.Stack(0xe6a8b1, 0x19, 0xc04250d8c0)
	C:/Go/src/runtime/debug/stack.go:24 +0xae
main.catchGoroutineError()
	C:/zincbox/go/src/github.com/gilbertchen/duplicacy-web/dwe/dwe_utils.go:26 +0x9b
panic(0xd16840, 0x146d6e0)
	C:/Go/src/runtime/panic.go:502 +0x237
main.listFilesHandler.func2.1(0xc0426b60a0, 0x17, 0xc0426b60b8, 0x4, 0xc0426b60bd, 0xd, 0xc0426b60cb, 0x75, 0xc0425b7b00)
	C:/zincbox/go/src/github.com/gilbertchen/duplicacy-web/dwe/dwe_backup.go:753 +0x26c
main.runDuplicacyExecutable(0xc042164340, 0x38, 0x0, 0x0, 0x0, 0xc0422660e0, 0x7, 0x7, 0x0, 0xc04250df10, ...)
	C:/zincbox/go/src/github.com/gilbertchen/duplicacy-web/dwe/dwe_utils.go:288 +0x73f
main.listFilesHandler.func2(0x0, 0x0, 0x0, 0xc04245d800, 0xc042678d38, 0x7, 0xc042085c20, 0xc0423a9130, 0xc0423086e0, 0xc042692d90)
	C:/zincbox/go/src/github.com/gilbertchen/duplicacy-web/dwe/dwe_backup.go:735 +0x299
created by main.listFilesHandler
	C:/zincbox/go/src/github.com/gilbertchen/duplicacy-web/dwe/dwe_backup.go:730 +0x6d0

Good news is that duplicacy is not crashing any longer :slight_smile:


#61

I did a clean install of 0.2.2 on one of my other computers. Attached are the logs from before and after I ran a check. If there’s something specific you’re looking for, let me know. I should also mention that with this version, Duplicacy is acting as if I haven’t run a check yet. On the Dashboard, it says “Some may not been checked recently.” And on the Storages page, it says “Not checked in last 3 days .” I ran the check function twice. I’m not sure if this is was expected to happen or not. Later tonight I will install 0.2.2 on one of my computers that has this issue and upload the log from that.

Before running check duplicacy_web-nocheck.txt (671.3 KB)
After running check duplicacy_web-aftercheck.txt (1.8 MB)


#62

@simon this error was caused by a path being both a directory and a file. If you run this version https://acrosync.com/duplicacy-web/duplicacy_web_installer_win64_0.2.3.exe it will print out the path in question to the log.