[SOLVED] Folders in GUI do not expand (both back-up and restore)

Please describe what you are doing to trigger the bug:
Subfolders do not expand in the following cases:

  • Selecting ‘Restore’ in the sidebar, and select a Backup ID and Revision. Then selecting the ‘Revision 1’ folder in the table below.
  • Selecting the local directory to be backed-up, folders do not expand in the ‘file explorer’.
  • Selecting a directory in the include/exclude menu.

Please describe what you expect to happen (but doesn’t):
Showing subfolders works in one instance: when selecting a google drive token file all subfolders are shown as expected:

Please describe what actually happens (the wrong behaviour):
Restoring: When clicking the folder shown in the table, it does not expand like it should:

Selecting backup dir: No subfolders are shown:

Include/exclude: Clicking the system folder does not expand.

The issue seems to be similar to this topic, but in my case no errors are shown in the duplicacy_web.log.

When opening the folder selection menu the following is shown in the log. No further logging happens when selecting different folders.

2022/01/12 09:30:24 POST /list_local_directory

I am running the web GUI through a Nginx reverse proxy, but the issue remains when accessing directly using local IP. I tested Firefox and Chrome.

Are you clicking on a folder name or a folder icon?

Oh wow…
I was clicking the names. When clicking the icons it expands just fine.

1 Like

This is a usability bug that people stumble on all the time.

1 Like

As a reminder to everyone — you can check the “solution” box under the comment that solved the topic as opposed to editing the title — this way the comment will be listed right under the question for the benefit of future readers.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.