Web UI filter include prevents backup

When I use the web UI to include directories Duplicacy didn’t back up any files. Though I’m not sure if this is a bug or user error :wink:

My root directory of the repository contains many directories. I only wanted to back up certain ones. I used the web UI to include the ones I want to back up. Adding each directory using the Include button resulted in:

+Dir1/
+Dir5/
+Dir8/

Then I added a custom exclude rule using the Add button to exclude everything else:

-*

For a resulting filter list of:

+Dir1/
+Dir5/
+Dir8/
-*

When I ran Duplicacy it did not find any files to back up despite the fact there are files in each of those directories.

I went to the filters file on the file system and changed the list to have asterisks after the directory paths like this:

+Dir1/*
+Dir5/*
+Dir8/*
-*

When I ran Duplicacy again it found and backed up the files in those directories.

When you create an include filter for a directory via the web UI why does it not have an asterisk after it if that is required in order for the files in that directory to be backed up? Or, am I doing something wrong with how I am specifying these filters via the web UI? (I am very new to Duplicacy so it’s certainly possible!)

Thanks!

It’s a bug that @gchen is planning to fix. See: Filters don't work as expected via the Web UI

As you already discovered, the current workaround is to manually specify filters in the web UI in order to get them to work.

2 Likes

Thank you @leerspace. I had searched around the forum but did not happen to find that thread. I appreciate your reply pointing me in the right direction.

1 Like

This has been fixed in 1.2.0.

4 Likes

Awesome! Thanks @gchen!