Duplicacy Web Edition 0.2.10 Beta is now available

web-ui

#168

What is your SFTP server? Another Synology? If so, add another slash to the url after server name before the path. See Chunk uploading error with Synology


#169

Indeed it is another Synology.

I added the leading slash, and now my storage looks like this:

sftp://Backup@192.168.2.17//Backup

That did it! Thanks!!


#174

Ouch - this won’t work for users (like me) who want to run it on a QNAP or Synology device with a vanilla Docker installation without dbus.

Any other way around this? Specifically I run docker in Swarm mode, so I’m unable to set a hostname (it’s not yet supported). I was about to graduate from CLI to a licensed user of the Web GUI, but need to make sure the license will be consistent.


#175

It appears to be impossible to add more than one Storage entity at this time. Can someone confirm whether or not they see the addition sign (+) after adding the first storage entry?


#176

Ignorant question: Can’t you just add in .dockerfile

run echo "hostname" > /proc/sys/kernel/hostname ?


#177

That was my misunderstanding of what was going on. I have already changed the way machine id is handled. It is now stored in the config directory along with the rest of duplicacy configuration so once generated it will never change for that virtual installation.

I will add override of a hostbame via environment variable or a file later today, good idea.

FWIW I run and test it on synology myself.


#178

Bottom left corner, there should be a green +.


#179

Been running the new web edition for just over a month and one thing has become clear - my graphs are looking a bit wonky:

Does everyone else’s graphs look like this?

Clearly, the New Revisions graph needs to be turned into a bar chart, coz those Bézier curves have got some serious lick!

However, my particular set of graphs seem to be broken, perhaps due to those localhost-0 et al, activities. Those were an initial run of each backup job, before they were assigned to proper schedule.

Plus the scheduled activities only seem to show the last week’s worth. If this is by design, I don’t mind that, but the graph extends more than a week. (Also, if it IS a design choice, a longer time span would be nice to have, unless there are performance reasons?)


#180

Scratch that. I forgot why I did not do it in the first place – hostname can be provided as --hostname argument when starting container, something like this:

docker run --name duplicacy-web-container          \
    --hostname duplicacy-web-docker                \
     --publish 3875:3875/tcp                       \
         --env USR_ID=$(id -u)                     \
         --env GRP_ID=$(id -g)                     \
      --volume /tmp/config:/config                 \
      --volume /tmp/logs:/logs                     \
      --volume /tmp/cache:/cache                   \
      --volume ~:/backuproot:ro                    \
      --volume /tmp/storage:/storage               \
               saspus/duplicacy-web 

Synology UI uses “Container Name” as a hostname. So nothing to be done there. It’s already working correctly. Let me know if your use case is different.


#181

That likely won’t work for me because I run the image via Docker Swarm, which means technically a worker can run on any (single) node and have a different hostname depending on how hostname is accessed via Duplicacy. That single instance is monitored by the swarm and restarted if necessary or relocated if a node goes down. Then duplicacy backs up shared storage.


#182

Tried it and it keeps getting “localhost” as the server name. Is there any way to accept hostname as an ENVIRONMENT variable like:

environment:
  - hostname:duplicacy-web-ui

Here is evidence of the problem:


#183

Yeah, I’ve read a bit docker swarm documentation and indeed this seems to be inherent problem.

I’ll add environment variable to override the hostname; at some point we shall consult with @gchen since all that pretending for the instance to be different host feels like stretching boundaries of the license.

At least there should be a way to ensure that only one instance is running at a time for each combination of of id-hostname-license.


#184

I just installed the latest beta and I’m wondering if there is a way to import the configuration from the GUI client ?

Thanks.
-DM


#185

I’ll add environment variable to override the hostname;

Apparently, this is impossible to do. Hostname is managed by the docker engine and cannot be changed within the running container.

Unless duplicacy adds an option to override system hostname when requesting license (which will likely never happen - this would circumvent the whole point of having licensing) I don’t think this would be feasible to do.

It seems to me that if you have swarm of instances capable of running duplicacy each instance shall be licensed separately.


#186

Apparently, not yet, but you can do that manually.

Moving data from ~./duplicay/preferences to ~/.duplicacy-web/duplicacy.json is rather laborious process involving format change, and it would be easier to just re-configure storages and schedules from scratch in the UI;

Copying exclusion filters however is trivial - just copy ./duplicacy/filters into corresponding location under ~/.duplicacy-web//filters/localhost/0 or just paste contents it in the UI.

I agree, duplicacy-web should be able to detect presence of old version and offer to import the config automatically.


#187

Totally agree. I’ve tied my Duplicacy instance to a single node.


#188

The Web Edition always refers to the computer it is running on as localhost. The only place where it needs the hostname is when it checks the license for localhost.


split this topic #189

5 posts were split to a new topic: Option to not launch browser when duplicacy web starts