Duplicacy Web Edition 0.2.10 Beta is now available

web-ui

split this topic #192

4 posts were split to a new topic: Trouble pruning with duplicacy web


#196

Hello, I’ve tested this web UI on my NAS but HubiC storage is missing. Is it normal ? The main reason I want to use Duplicacy is that it’s still support HubiC but if that will no more be the case, I’ll have to change my provider and in that case I’ll probably not need Duplicacy anymore as other providers are supported by my NAS backup app natively. I’ve tried in CLI but it’s always failing at some point and each command with Hubic link inside need to give the token location, it’s quite cumbersome, it should be asked only once and then stored for good.


#197

One quick question if I may- is there a target date for a general release of the web gui? Just curious when it is planned to come out of beta.

Thanks!


#198

First of all, I love the Web Edition. I probably wouldn’t still be using Duplicacy without it. So great job, and I’m looking forward to seeing it be improved further.

A couple suggestions:

Would it be possible to change it so the stats are updated even if the check command reports “Missing Chunks”? The problem I’m having is that my stats are not updated most of the time because the last backup in the check command usually reports “Missing Chunks”. And I think that’s because I’m running backups every 15 minutes, but the check command takes much longer, so there’s usually at least one backup that starts while the check command is running, which seems to throw it off. It would be great if the stats would update even if the check command reports “Missing Chunks” for this reason. Right now my charts and summaries are fairly useless because they’re usually showing 0.

My other suggestion is that it would be great to have a simpler way to configure backups and schedules. It’s pretty painful right now when you have multiple backups and multiple destinations. I have to create a separate backup for each combination, which means I have to schedule a separate backup for each one, too. I also prefer to prune each backup separately so that the computer the backup is for is in control of it, which means I have to schedule a separate prune for each one, too. It’s nice having the flexibility to configure it however you want, but most of the time it would be nice to have a more consolidated way to create a backup, specify which destinations it should go to, and how often it should run and be pruned. It’d be great if the check commands were just run automatically too instead of having to manually schedule those since the stats are worthless otherwise. I realize the Web Edition is a wrapper around the CLI, but perhaps you could have a way to abstract it more and make it more convenient to set up backups? It’s just very tedious right now.

Thank you!


#199

HubiC is closing down so we won’t add HubiC to the web UI.


#200

There is still on more update planned for the beta version before the final release. The target date (hopefully) is end of March or beginning of April.


#201

I wonder if something else caused “Missing Chunks”. An incomplete backup won’t, because the snapshot file is only uploaded at the last step of backup. The check command will see chunks first, and then the snapshot file.


#202

Registration is closed but the service remain open for current users. Synology has cut the cord, they are a commercial company so I can understand but Duplicacy is one of the last hope for HubiC user and it’s open source so I would hope that it stays offering all options. If it’s not the case I’ll stop losing my time and pay more for another service.


#203

By default, if you just go with the defaults with the Prune command in the GUI, it does not appear to do anything. I think this is because it requires you to select -a or specify a snapshot ID. “Experts” will deal with this issue and add -a to the command line. But I assume the GUI is for non experts, so I suspect that they should be prompted to either select a snapshot ID or select “All”.

Likewise, I want to remove some old and not used “Snapshot-IDs” a shared storage. I am not a Duplicacy newbie, but it is not clear how I do that, and what impact it has on 2 stage fossil collection etc. Maybe it might be nice to put an option in the GUI to prune and remove a complete Snapshot-ID. I assume this will prevent old, not used snapshot-ids holding up unused chunks being deleted? But I am guessing there is a little more to it than that, and would I be right in guessing that if there has not been a snapshot for a little while (maybe 7 days), it will ignore that and delete fossils?


#204

I to have seen this. ie what I assume in Check complaining about missing chunks when a backup is running. This surprised me a little, for the reason you outline. Rerun of the check once backup is complete fixes the issue. If not backup, I would be curious what the other thing might be.


split this topic #206

2 posts were split to a new topic: Connection freeze with Wasabi


#207

I’m having trouble with the encryption password on a headless Linux box (an LXC container on Proxmox, technically).

Every time I start Duplicacy Web Edition, it asks for the encryption password (in the web UI). I understand that’s used to decrypt the other passwords. However, this a headless box, and I’m running Duplicacy automatically on startup. I need it to just start working once it comes up without waiting for a password. I’m currently running Duplicacy Web Edition as root using cron on startup.

I’m checking the box to save the password to the keyring, but it doesn’t seem to work. I installed gnome-keyring and tried again, but it still didn’t work.

Can you give me some direction on where to check for errors or otherwise figure out how to get it to save the encryption password so I don’t have to remember to go enter it every time that box is restarted?

EDIT: I just noticed these two lines at startup in duplicacy_web.log:

2019/03/18 12:37:07 Failed to get the value from the keyring: keyring/dbus: Error connecting to dbus session, not registering SecretService provider: dbus: DBUS_SESSION_BUS_ADDRESS not set
2019/03/18 12:37:07 Failed to decrypt the testing data using the password from KeyChain/Keyring: crypto/aes: invalid key size 0

I’m happy to store the passwords unencrypted in the preferences file, if that’s an option. But I don’t see a way to do that with the UI, and I’m not sure if I should edit the file directly.


#208

Duplicacy uses dbus to communicate with gnome-keyring so you need to set up dbus as well. I believe you need to set DBUS_SESSION_BUS_ADDRESS by running export $(dbus-launch).


#209

Hmm. I’m trying to keep this as simple as possible. Is there a way I can just store the unencrypted passwords for my storages in the config file?

From what I’m reading, gnome-keyring isn’t really intended for headless setups and definitely isn’t intended for root, so I’d prefer not to come up with a dirty/tricky workaround. I guess I could run Duplicacy as a different user, but I’d really just like to do the easiest thing here.


#210

You can do that with the set command: Set command details .


#211

But don’t I need to set it in the Duplicacy Web Edition config file? That command would only work for each Duplicacy repository it generates automatically, right?


#212

The set command is used from the cli. I’m not sure though how you should use that command with the repositories created by the web gui.